OMA CP received settings are not included in APN list properly

VERIFIED FIXED in 2.1 S5 (26sep)

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: brg, Assigned: arthurcc)

Tracking

({regression})

unspecified
2.1 S5 (26sep)
x86
Mac OS X
regression

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 fixed)

Details

(Whiteboard: [p=1][ETA: 9/15])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8482641 [details]
2014-08-29-13-26-28.png

Flame, master(2.1), Gecko-2fbbb04.Gaia-59bd661, the setting received is not properly included in the APN list. see screenshot.

The new profile received via OMA CP is called Telefonica and the APN name is telefonica.es. The list must include "Telefonica" instead of "telefonica.es"

The expected behaviour is to have a list of APN like:
Telefonica (active by default)
Jazztel Internet
Movistar
Are there differences other than the APN name?
Flags: needinfo?(beatriz.rodriguezgomez)
(Reporter)

Comment 2

4 years ago
The identifier is properly included in APN Editor (see new attachment) but password, proxy host and proxy port are not included (already reported in bug 1061448)
Flags: needinfo?(beatriz.rodriguezgomez)
(Reporter)

Comment 3

4 years ago
Created attachment 8482712 [details]
APN Editor
(Reporter)

Comment 4

4 years ago
[Blocking Requested - why for this release]: It was working fine in 2.0. This is a cert. blocker.
blocking-b2g: --- → 2.1?
regressionwindow-wanted to find the regressed bug.
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 6

4 years ago
I guess this was caused after the new UX refresh landed in APN settings (bug 1032629)

Comment 7

4 years ago
Triage: regression, blocking.
blocking-b2g: 2.1? → 2.1+
Created attachment 8484897 [details]
link to https://github.com/mozilla-b2g/gaia/pull/23762

EJ, please check this simple patch when you are back, thanks!
Attachment #8484897 - Flags: review?(ejchen)
There is no environment for testing OMA CP here. Beatriz, could you help check if this patch (and the one for bug 1061448) fix the issue? Thanks!
Flags: needinfo?(beatriz.rodriguezgomez)
Whiteboard: [p=1][ETA: 9/15]
Target Milestone: --- → 2.1 S5 (26sep)
(Reporter)

Comment 10

4 years ago
Sure! Juanjo will help with the testing/feedback. Moving the ni to him.
Flags: needinfo?(beatriz.rodriguezgomez) → needinfo?(juanjose.iglesias)
(Reporter)

Comment 11

4 years ago
The patch seems not to be working :-(
After receiving the message and install it, the APN list is empty (blank).
Please review your patch and let us know if you need logs or more testing.
Flags: needinfo?(juanjose.iglesias)
Keywords: regressionwindow-wanted
Assignee: nobody → arthur.chen
Status: NEW → ASSIGNED
May I know the content of the APN used for testing? Is there any JavaScript error?
Flags: needinfo?(juanjose.iglesias)

Comment 13

4 years ago
I have tested it using Flame 2.1 (Gecko f816f7e Gaia c7b55ed) with the patch, from the Comment 8, installed. 

The APN list is not empty. Before of the OMA CP message is received, the APN list is created with the APN profiles stored in the phone. After, the profile received via OMA CP is added in this list. 

The new profile received via OMA CP is properly included in the APN list like "Telefonica".
Flags: needinfo?(juanjose.iglesias)
Comment on attachment 8484897 [details]
link to https://github.com/mozilla-b2g/gaia/pull/23762

Thanks Arthur, this patch looks good to me. r+.
Attachment #8484897 - Flags: review?(ejchen) → review+
Thanks, EJ.

master: bc48cbd9e7b871cc648a525761bd6d512e91d741
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
Resolution: --- → FIXED
Comment on attachment 8484897 [details]
link to https://github.com/mozilla-b2g/gaia/pull/23762

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1032629 (APN UX refresh)
[User impact] if declined: Low
[Testing completed]: Manual test completed. Unit tests added.
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: N/A
Attachment #8484897 - Flags: approval-gaia-v2.1?(bbajaj)
Attachment #8484897 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+

Comment 18

4 years ago
I have tested using flame master (Gecko 745dcf1, Gaia 9306e43) and flame v2.1 (Gecko 604fdf4, Gaia 7f738ed), in both case the APN is registered correctly in the APN list. 

After receiving the message and install it, the APN is called by profile name and not by APN name in the list. 

The list include "Telefonica" instead of "telefonica.es", like it is expected.
(Reporter)

Comment 19

4 years ago
Thanks for fixing it. Bug marked as Verified per comment 18.
Status: RESOLVED → VERIFIED

Updated

4 years ago
status-b2g-v2.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.