If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[PP]Prefs50.js file is being written over each apprunner launch

VERIFIED FIXED

Status

Core Graveyard
Profile: BackEnd
P3
major
VERIFIED FIXED
18 years ago
8 months ago

People

(Reporter: Grace Bush, Assigned: neeti)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Steps to reproduce:
On build 1999072617
1. launch apprunner
2. exit apprunner
3. contents of  prefs50.js file is duplicated

expected results: file is updated with any changes made
actual results: each launch will add to contents of prefs50.js file (repeat of
what is there plus changes if any)

Mac and Win32 builds do not exhibit this behavior
**editing prefs will add to the file, last series of statements will reflect
changes, manual edits to this file may be necessary

Updated

18 years ago
Assignee: selmer → dp

Comment 1

18 years ago
DP, I believe this should go to Neeti but I wanted you to see it first.  Also,
the behavior even on Linux should be that the last defined value wins.  So the
problem is really that the file will grow quite large, not that other observable
behaviors should be wrong.

Updated

18 years ago
Assignee: dp → neeti
(Assignee)

Comment 2

18 years ago
Grace, could you check if this is still happening. I am not able to reproduce
the problem with today's build.
Thanks,
Neeti

Comment 3

18 years ago
Grace is on vacation this week.
(Assignee)

Comment 4

18 years ago
Paul, could you check if this happening, because I was not able to reproduce the
problem.

Thanks,
Neeti

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 5

18 years ago
This is fixed with 8/2 builds. No more appending of the prefs file.

Updated

18 years ago
Component: Profile Manager → Profile Manager BackEnd

Comment 6

18 years ago
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.