POST fails when the post target is the same as the source page

VERIFIED DUPLICATE of bug 103850

Status

()

--
major
VERIFIED DUPLICATE of bug 103850
17 years ago
17 years ago

People

(Reporter: ct7, Assigned: rods)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Sun has some sort of weird servlet that handles downloading binaries from their
mirrors -- it provides a multi-page process for collecting all of the requisite
data and ultimately redirects the browser to a specific URL to download the
correct binary.  With Mozilla 0.9.5/Linux, when you click on a form button to
move to the next page (which has the exact same URL as the current page),
Mozilla will just redisplay the current page, instead of posting the form data
and displaying the result.

This failure happens when the cache checking interval is set to "Automatic";
setting the interval to "Check every time" or "Once per session" or "Never"
allows the servlet/forms to work correctly.  Presumably the "Automatic" setting
isn't recognizing that the current page was the result of a POST, and thus
changing the POST parameters (and POSTing to the same URL) might result in a
completely different page.
To reproduce this problem, start with a fresh browser and a clean cache.  Go to
a Sun download page (such as http://java.sun.com/j2se/1.3.0/) and then click on
a button to download a particular product (ex: continue).  You will be
redirected to http://java.sun.com/Download5 and prompted to accept or decline
the license.  Click the ACCEPT button and instead of being presented with a list
of mirror sites for that product, you'll get the license agreement again.  If
you shift-click the reload button (and accept the POSTDATA dialog) you'll get
the correct page (at the same URL).  The same thing will happen when you try to
click one of the mirror site buttons.

*** This bug has been marked as a duplicate of 103850 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.