Closed Bug 1061725 Opened 8 years ago Closed 8 years ago

CERT_DecodeTrustString fails to call PORT_SetError if trust string is invalid

Categories

(NSS :: Libraries, defect)

3.17.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jdennis, Assigned: Cykesiopka)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20140730101922

Steps to reproduce:

call CERT_DecodeTrustString() with an invalid trust string.


Actual results:

Returned SECFailure but because it never called PORT_SetError() the error returned by PR_GetError() is garbage.


Expected results:

PR_GetError() should have returned a meaningful error.
Assignee: nobody → cykesiopka.bmo
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8568972 - Flags: review?(emaldona) → review+
https://hg.mozilla.org/projects/nss/rev/483fbe78c2b2
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 3.18
You need to log in before you can comment on or make changes to this bug.