New messages in thread do not highlight thread listing

VERIFIED INVALID

Status

defect
VERIFIED INVALID
18 years ago
15 years ago

People

(Reporter: cice, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

18 years ago
If viewing messages in INBOX in decending, threaded order...reading all messages
in a thread will dim the top level message when thread is collapsed. (as expected)

If a new message comes into that thread, the top level message still stays
dimmed.  So previously read threads with new messages do not indicate there are
new messages in that thread if collapsed.

This behavior results in new messages being unnoticed until the reader opens the
thread to find (surprise) new unread messages that have been sitting.

If a new message comes into a previously read thread, the top level message
should hilite if not already expanded.

Chris

Updated

17 years ago
Summary: New messages in thread do not hilite thread → New messages in thread do not highlight thread listing

Comment 1

17 years ago
Chris, does this problem still occur with the latest builds?

Try 1.0 RC1.  If this problem no longer occurs, please resolve the bug.  If it
still occurs, let us know.

Also, you're talking about newsgroups, or what?
Reporter

Comment 2

17 years ago
I am using NS6.2.2, and the problem still occurs.  This is in the *mail* client,
reading imap mail messages.

Try this....send yourself a mail, subject 'test' (make sure the main mail window
is in threaded view).  Check messages.  Read the new message.  Reply to it,
"test123" in body, send.  Check messages again.  Ding...new mail will arrive,
but the parent message 'test' remains "read".  However, it's now the leader for
a thread where it wasn't before.  Frequently, unread messages will hide in
collapsed threads whose parent shows 'read'.  I have to open all threads to see
where the new mail went, or change the view to 'unread' to find them.

Perhaps there's a new hilite state... "read", "unread", "thread
unread"...meaning there are unread messages in this *collapsed* thread.

I can try w/1.0rc1 and see if that addresses it, will update success/fail.

Comment 3

17 years ago
Mozilla does not show threaded view... when I tried what you said, I had one
listing called "test" and another listing called "Re: test"... Mozilla does not
collapse similar messages into one listing.

It looks like a Netscape-only bug.  For now I will render it INVALID.  If you
try Mozilla 1.0RC1 and the same bug occurs (although I don't see how it could,
seeing as how Mozilla does not use threaded view), feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → INVALID

Comment 4

17 years ago
Chris, with the 6.2.3 released Netscape build and later, if you sort by thread
in an IMAP folder, the top level message will indicate tehre is an unread thread
by displaying a green down arrow, hope this helps you.  Verified 
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.