Closed Bug 1061760 Opened 7 years ago Closed 7 years ago

mstange's dumping ground for experimental patches that get rid of plugin widgets on OS X

Categories

(Core :: Widget: Cocoa, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1092630

People

(Reporter: mstange, Unassigned)

Details

Attachments

(13 files)

890 bytes, patch
Details | Diff | Splinter Review
1.07 KB, patch
Details | Diff | Splinter Review
1.61 KB, patch
Details | Diff | Splinter Review
1.24 KB, patch
Details | Diff | Splinter Review
894 bytes, patch
Details | Diff | Splinter Review
1.41 KB, patch
Details | Diff | Splinter Review
2.72 KB, patch
Details | Diff | Splinter Review
1.82 KB, patch
Details | Diff | Splinter Review
2.45 KB, patch
Details | Diff | Splinter Review
4.23 KB, patch
Details | Diff | Splinter Review
1.12 KB, patch
Details | Diff | Splinter Review
9.88 KB, patch
Details | Diff | Splinter Review
64.62 KB, patch
Details | Diff | Splinter Review
No description provided.
because there's no longer an NSView that can send plugin focus events when becoming firstResponder
Regular Gecko key events get targeted to the focused frame appropriately. (It looked to me like that's not the case for plugin key events, but I haven't verified that.)
This always treats all plugins as completely visible and puts their top left corner at 0,0.
Since the plugin now thinks it's at 0,0, event coordinates need to be made relative to the plugin.
One of the few things remaining is that key events still come with an attached plugin event.
mstange++++++++++++++++++++++
Bug 1092630 has landed, so I'll close this bug. Yay!
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1092630
You need to log in before you can comment on or make changes to this bug.