jsapi-tests should be run on ARM simulator as part of SM(ARM)

RESOLVED DUPLICATE of bug 1072008

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 1072008
3 years ago
3 years ago

People

(Reporter: rankov, Unassigned)

Tracking

Trunk
ARM
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
The jsapi-tests contain testJitMoveEmitterCycles test that is specific for ARM simulator. Therefore they should be run on SM(ARM) too.
(Reporter)

Comment 1

3 years ago
Note that these tests are currently broken. Please wait for bug 1058024 to land first.
Depends on: 1058024
This bug should probably be a more generic "SM shell builds should run jsapi-tests" bug rather than being arm-specific.
I really should have used this bug. But I piled together a bunch of changes to the spidermonkey build script in bug 1072008, including running jsapi-tests and jstests on the shell builds.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1072008
You need to log in before you can comment on or make changes to this bug.