If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Figure out how to express test addon xpi generation in moz.build

RESOLVED DUPLICATE of bug 988938

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 988938
3 years ago
3 years ago

People

(Reporter: ted, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Right now there's a Makefile that does this:
http://hg.mozilla.org/mozilla-central/annotate/c360f3d1c00d/toolkit/mozapps/extensions/test/Makefile.in#l11

Ideally we'd be able to express that in moz.build. Even building on top of my patches from bug 883954 there's no way to do it that's not super-verbose, you'd have to write something like:
GENERATED_FILES += [ '!/_tests/xpcshell/toolkit/mozapps/extensions/test/xpcshell/addons/whatever.xpi']
GENERATED_FILES['!/_tests/xpcshell/toolkit/mozapps/extensions/test/xpcshell/addons/whatever.xpi'].script = 'makexpi.py'

...which is actually worse.

Anyone have thoughts on this? Do we just punt and invent a TEST_XPIS variable?
how about saying the generated file is whatever.xpi and that its destination is '!/_tests/xpcshell/toolkit/mozapps/extensions/test/xpcshell/addons' ?

Comment 2

3 years ago
We do this in browser/experiments also. I think gps actually filed this already, but I can't find it right now.

Comment 3

3 years ago
I'm pretty sure I filed this bug as well. Coincidentally I've also been thinking about this problem because $(MAKE) XPI_NAME=foo hacks in Makefile.in are preventing build system optimizations that reduce no-op build times by 25%.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 988938
You need to log in before you can comment on or make changes to this bug.