[Email] User cannot load inbox of Outlook/Hotmail account correctly

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::E-Mail
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Brogan Zumwalt [Inactive], Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8482935 [details]
Logcat

Description:
When user signs into an Outlook or Hotmail email account on device the user is taken to an inbox page that never loads. The sync button spins continuously and no emails ever load. Only "Inbox", "Local Drafts", and "Outbox" folders show up in drawer.

This issue occurs regardless of whether the account is set up automatically or manually, the sync rate is manual or automatic, the days to sync is set to any setting, or whether the user is logging into a @Hotmail or @Outlook account.

Multiple Outlook and Hotmail accounts were tried with this bug with only two of the accounts functioning (one ceased to function after further testing.) Users could log into all accounts on computer successfully.

Repro Steps:
1) Update a Flame device to BuildID: 20140902040205
2) Launch email app
3) Enter valid account information for Outlook account
4) Continue to inbox
  
Actual:
Account and inbox for email never fully loads.
  
Expected: 
Email account loads as expected.
  
Environmental Variables:
Device: Flame 2.1 Master
BuildID: 20140902040205
Gaia: 44bf2e3bc5ddea9db9a8c851bd353cb234aa883c
Gecko: c360f3d1c00d
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Repro frequency: 6/7, 86%
See attached: video clip & logcat
Youtube Link: http://youtu.be/1YcfgUxq7kE
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Log shows we're using our autoconfig properly and dying when getting the command URL in syncFolderList.

Suggest we revisit a little later as it looks like there are indications of problems on MS's end at http://downrightnow.com/hotmail and http://downdetector.com/status/outlook
Adding qawanted to retry this when hotmail and outlook are more stable.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qawanted
I've checked 2 Hotmail and 2 outlook accounts with no problems logging in.
Repro 0/4

Latest 2.2 Engineering build.
Environmental Variables:
Device: Flame Master
BuildID: 20140903062451
Gaia: 52670853c17fc0d3d33065c667c0ce124c93b98f
Gecko: 5e9826980be5
Version: 35.0a1 (Master) 
Firmware Version: v123
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.