Closed Bug 1061943 Opened 5 years ago Closed 5 years ago

Purge all GradientCache on memory-pressure

Categories

(Core :: Graphics, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla35
blocking-b2g 2.0+
Tracking Status
firefox33 --- wontfix
firefox34 --- fixed
firefox35 --- fixed
b2g-v2.0 --- fixed
b2g-v2.0M --- fixed
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: sotaro, Assigned: sotaro)

References

Details

Attachments

(1 file)

On memory-pressure event, GradientCache is not purged. It seems better to purge on memory-pressure.
Assignee: nobody → sotaro.ikeda.g
Blocks: 1049251
Attachment #8483032 - Flags: review?(jmuizelaar)
[Blocking Requested - why for this release]: Blocks bug 1049251.
blocking-b2g: --- → 2.0?
blocking-b2g: 2.0? → 2.0+
Attachment #8483032 - Flags: review?(jmuizelaar) → review+
https://hg.mozilla.org/mozilla-central/rev/b9f45ad6a96e
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Due to recent policy changes, all patches need approval for uplift regardless of blocking status. Please request b2g32 and aurora approval on these when you get a chance. Sorry for the inconvenience :(
Flags: needinfo?(sotaro.ikeda.g)
Comment on attachment 8483032 [details] [diff] [review]
Purge all GradientCache on memory-pressure

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): None
User impact if declined: User might face that more applications get killed.
Testing completed: Locally tested.
Risk to taking this patch (and alternatives if risky): Low
String or UUID changes made by this patch:
Attachment #8483032 - Flags: approval-mozilla-b2g32?
Attachment #8483032 - Flags: approval-mozilla-aurora?
Flags: needinfo?(sotaro.ikeda.g)
Attachment #8483032 - Flags: approval-mozilla-b2g32?
Attachment #8483032 - Flags: approval-mozilla-b2g32+
Attachment #8483032 - Flags: approval-mozilla-aurora?
Attachment #8483032 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.