Closed Bug 1061983 Opened 7 years ago Closed 7 years ago

'open' is hardcoded on lockscreen

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S4 (12sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: tchevalier, Assigned: tchevalier)

References

Details

(Keywords: late-l10n)

Attachments

(2 files)

Attached image Flame 2.1
Looks like we have a hardcoded string, https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/lockscreen_notification_builder.js#L103

2.1 is affected, so adding late-l10n as we are past FL (final string freeze is in two weeks).
Attached file Master PR
Note: I didn't test on device yet
Attachment #8483108 - Flags: review?(timdream)
Also, looks like the string is not capitalized, regarding the UX spec https://mozilla.app.box.com/s/gsklu2bl6ii98sbn8bsk/1/2189547211/18997083751/1
Not sure if it's what we want
Hi Rob,

Is the string 'open' or 'Open'? (Just to be sure)
Flags: needinfo?(rob.a.mcdonald)
Comment on attachment 8483108 [details] [review]
Master PR

Thanks for catching the issue. Please redirect the next review to :snowmantw.
Attachment #8483108 - Flags: review?(timdream) → feedback+
Flags: needinfo?(gweng)
The spec in Bug 1023818 shows it's 'open' rather than 'Open'.
Flags: needinfo?(gweng)
And maybe the patch can follow what Tim addressed at the GitHub page.
Alright, thanks for the feedback, let's move on with 'open' :)
Flags: needinfo?(rob.a.mcdonald)
Attachment #8483108 - Flags: review?(gweng)
Comment on attachment 8483108 [details] [review]
Master PR

Okay, it looks good and works on device
Attachment #8483108 - Flags: review?(gweng) → review+
Thanks Greg, setting checking keyword
Keywords: checkin-needed
master: https://github.com/mozilla-b2g/gaia/commit/921e0d335137cd7cc8e963eedbb1669ea52e3ca5
Assignee: nobody → tchevalier
Status: NEW → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S4 (12sep)
[Blocking Requested - why for this release]:
English string on lockscreen
blocking-b2g: --- → 2.1?
Théo, please set approval flag on the patch?
blocking-b2g: 2.1? → 2.1+
Flags: needinfo?(tchevalier)
Comment on attachment 8483108 [details] [review]
Master PR

oops, missed this change in uplift process

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1043103
[User impact] if declined: English string on lockscreen when tapping on notification
[Testing completed]: Tested on 2.2, works fine in French
[Risk to taking this patch] (and alternatives if risky): very low
[String changes made]: Added one string to system.properties
Attachment #8483108 - Flags: approval-gaia-v2.1?
Flags: needinfo?(tchevalier)
Out of curiosity: do we need approval on the patch when the bug is already marked as 2.1+?
(In reply to Francesco Lodolo [:flod] (offline from Aug 31 to Sep 7) from comment #14)
> Out of curiosity: do we need approval on the patch when the bug is already
> marked as 2.1+?

Yes, that's new in 2.1. YAY THAT!
Attachment #8483108 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
I verified that this issue is fixed using French on Flame 2.1(319mb) and on the Flame 2.2(319mb).

The string "Open" is translated properly. 

Flame 2.2

Environmental Variables:
Device: Flame Master (319mb)
Build ID: 20140908040204
Gaia: c71fd5d8c9c7cb021c97e5e9fbb29f92b50a084d
Gecko: 892768985915
Version: 35.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1

Environmental Variables:
Device: Flame 2.1(319mb)
Build ID: 20140908000204
Gaia: a8e4d26555e5713ec6c72270cfd0cfabc096a0d3
Gecko: 746f24f9d21d
Version: 34.0a2
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
You need to log in before you can comment on or make changes to this bug.