[Email] Account setup does not fail/error out when setting up new account with invalid credentials

VERIFIED FIXED in 2.1 S4 (12sep)

Status

Firefox OS
Gaia::E-Mail
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Jordan de Geus(JordanD), Assigned: jrburke)

Tracking

({regression})

unspecified
2.1 S4 (12sep)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected)

Details

(Whiteboard: [2.1-exploratory], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8483159 [details]
logcat_20140902_1611.txt

Description:
When users enter the E-mail app, upon entering a invalid/incorrect email/password users will see the app constantly sits on "Setting up account" with a spinning circle.

Repro Steps:
1) Update a Flame to 20140902040205
2) Select Email> Enter a Name
3) Enter a invalid email/password (email: name@gmail.co - password: 12345)
4) Observe email app sits on "Setting up account"

Actual:
Account setup does not fail out when setting up a new account using invalid email/password

Expected:
Setup returns user to sign-in/sign-up stating they entered invalid username/password

Environmental Variables:
Device: Flame Master (319mb)
Build ID: 20140902040205
Gaia: 44bf2e3bc5ddea9db9a8c851bd353cb234aa883c
Gecko: c360f3d1c00d
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency: 3/3
See attached: Video and logcat
http://youtu.be/x88OHGZSSfQ
(Reporter)

Comment 1

4 years ago
This issue DOES occur on Flame 2.1 (512mb), Open C 2.1

Actual: Email app constantly sits on "Setting up account" when attempting to setup an account with invalid username/password

Flame 2.1

Environmental Variables:
Device: Flame Master (512mb)
BuildID: 20140902040205
Gaia: 44bf2e3bc5ddea9db9a8c851bd353cb234aa883c
Gecko: c360f3d1c00d
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Open C 2.1

Environmental Variables:
Device: Open_C 2.1 Master
BuildID: 20140902040205
Gaia: 44bf2e3bc5ddea9db9a8c851bd353cb234aa883c
Gecko: c360f3d1c00d
Version: 34.0a1 (2.1 Master)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

--------------------------------------------------------------------------

This issue DOES NOT occur on Flame 2.0 (319mb), and Open C 2.0

Actual: Users are returned to email sign in/sign up screen stating they entered invalid email/password

Flame 2.0

Environmental Variables:
Device: Flame 2.0 (319mb)
BuildID: 20140902000202
Gaia: 449d8db9b3ea1f9262db822c37ef2143477172b7
Gecko: 40d74e0bbcf5
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Open C 2.0

Environmental Variables:
Device: Open C 2.0
BuildID: 20140902000202
Gaia: 449d8db9b3ea1f9262db822c37ef2143477172b7
Gecko: 40d74e0bbcf5
Version: 32.0 (2.0)
Firmware Version: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(Assignee)

Comment 2

4 years ago
The pull request for bug 1061932 has a fix that fixes this issue too, so marking it dependent on that bug, and will close out this bug as marked as fixed with that changeset when it lands.
Assignee: nobody → jrburke
Status: NEW → ASSIGNED
Depends on: 1061932
Target Milestone: --- → 2.1 S4 (12sep)
(Assignee)

Comment 3

4 years ago
Fixed in the commit mentioned in bug 1061932 comment 6.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
[Blocking Requested - why for this release]:

This is a regression so nominating this 2.1? since the it never times out when the user puts in the wrong credentials. According to comment 3 this has been fixed so not adding a regression-window on this issue.
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
triage: clearing nomination. per comment 3 this was fixed in bug 1061932 and that has been uplifted to the 2.1 branch.
blocking-b2g: 2.1? → ---

Comment 6

4 years ago
If user input wrong account, the page will redirected to manual page to set up again.

[Environment]
Gaia      944e5b4582c4efa1b67cd33245dbb8f6aa25d09f
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/7546fedad918
BuildID   20140914160203
Version   34.0a2
ro.build.date   Fri Jun 27 15:57:58 CST 2014
ro.bootloader   L1TC00011230
ro.build.version.incremental   110

[Result]
PASS
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [COM=Gaia::E-Mail][QAnalyst-Triage+]
You need to log in before you can comment on or make changes to this bug.