[Email/IMAP] Creating mail account fails despite successful IMAP login

RESOLVED INVALID

Status

Firefox OS
Gaia::E-Mail
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Ph.Le., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20140716183446

Steps to reproduce:

Firefox OS Simulator 1.3

Create mail account. Settings are IMAP/SSL/993 and SMTP/STARTSSL/587/.
They can be set by autoconfig or manually, the result is the same.
Autoconfig is OK under Thunderbird.


Actual results:

The server log shows that connection and login to IMAP server is successful.
But Firefox OS reject account creation [bad-user-or-pass].



Expected results:

The account creation should go on.
Can you provide a logcat of the account creation process?  It will include more extensive details on the IMAP or SMTP errors.  Thanks!  Please see https://wiki.mozilla.org/Gaia/Email/RequiredBugInfo for instructions on how to do that.
Flags: needinfo?(bugzilla)
(Reporter)

Comment 2

3 years ago
Yes indeed. Before filing this bug I struggled for hours trying to have adb with Firefox OS Simulator. I never found any information about adb AND simulator.
Using Firefox App Manager I can start E-MAil app and click a nice DEBUG button. It results in this warning. 

The Web Console logging API (console.log, console.info, console.warn, console.error) has been disabled by a script on this page. 

Other App doesn't show this warning.

I am ready to try any suggestion to obtain the necessary log.
Flags: needinfo?(bugzilla)
Ah, the Firefox OS simulator is just a desktop version of b2g (b2g-desktop).  We redirect our console logs to the dump() command because on devices because this is how we get output via adb.  For b2g-desktop dump() just goes to stdout.  Unfortunately at least the Web IDE likes to eat the output and its version of b2g-desktop is weird.

The simplest thing is just to download a real b2g-desktop instance and run it from the command line so you can see/capture our stdout output.  That way you can also use a more modern build of Firefox OS (1.3 is regrettably quite old.)

There are docs at https://developer.mozilla.org/en-US/Firefox_OS/Building_the_B2G_desktop_client and its link to http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-central/ is good, although if you want a more stable release http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-b2g32_v2_0/ might be better.

Then see https://developer.mozilla.org/en-US/Firefox_OS/Building_the_B2G_desktop_client#Running_the_desktop_client to run the b2g-desktop instance.
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

3 years ago
It is USER error. Thanks for pointing me to debugging tools.

- What was the error? On the mail server, the authentification is not the same for IMAP server and for SMTP server. The IMAP probe was OK but the SMTP probe failed. This can be seen as a server configuration issue

- Why had I difficulties finding out my error ? Because I am new to autoconfig and B2G, I tried first with Thunderbird, which was OK, and afterwards with B2G which failed. Hence I wrongly thought it was a B2G issue.  

- Why Thunderbird was OK ?: Because Thunderbird only probe IMAP when creating a new account. It does not probe SMTP. I did not test sending an email, which should have failed.

- How I found the error ?: As instructed by Sutherland, I used b2g-desktop. For having logs, on MacOS, it's enough to open Console.app

- What next ?: For autoconfig to work, I have to unify passwords in both IMAP and SMTP servers, as usually mail UA quick config asks for only one password.
Glad to hear you figured out the problem.  Note that we did implement support for having different login credentials for SMTP from IMAP on bug 805501, so if you use Firefox OS v2.0 or later you can just use manual config.  (Although I would recommend unifying the credentials if you can, since autoconfig is more fun than manual config, when it works! :)
You need to log in before you can comment on or make changes to this bug.