Open new tab button has no accessible name

VERIFIED FIXED in Firefox 65

Status

()

defect
VERIFIED FIXED
5 years ago
6 months ago

People

(Reporter: stsigankov, Assigned: Gijs)

Tracking

({access, regression})

32 Branch
Firefox 65
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox-esr60 wontfix, firefox64 wontfix, firefox65 verified, firefox66 verified)

Details

Attachments

(2 attachments)

Posted image 1.png
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20140716183446

Steps to reproduce:

win7

Tried to find the MSAA Name for Open new Tab button.


Actual results:

The name is empty.
Screen attached.


Expected results:

Name should be not empty.
Like it was in previous versions.
Component: Untriaged → Disability Access
Confirmed. This looks like the tooltiptext got lost for that button at some point. Gijs, can you take a look?
Component: Disability Access → Tabbed Browser
Flags: needinfo?(gijskruitbosch+bugs)
Keywords: access, regression
We dynamically associate tooltips with some buttons now so that we can include the shortcut in the tooltip. So there's no tooltiptext attribute anymore. Marco, what would be a good substitute if we can't bring back the tooltiptext? Should we just use aria-label ?
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(marco.zehe)
Blocks: 940116, 979479, 947344
Status: UNCONFIRMED → NEW
Component: Tabbed Browser → Toolbars and Customization
Ever confirmed: true
Flags: firefox-backlog+
OS: Windows 7 → All
Hardware: x86_64 → All
Summary: Open new tab button has no MSAA name → Open new tab button (and potentially various other buttons) has (have) no accessible name
How is that dynamic tooltip association done? Are there no tooltip texts any more getting associated to the XUL elements, even though JavaScript? If that's indeed the case, then aria-label is probably the best substitute, yes.
Flags: needinfo?(marco.zehe) → needinfo?(gijskruitbosch+bugs)
(In reply to Marco Zehe (:MarcoZ) from comment #3)
> How is that dynamic tooltip association done? Are there no tooltip texts any
> more getting associated to the XUL elements, even though JavaScript? If
> that's indeed the case, then aria-label is probably the best substitute, yes.

Using a tooltip attribute, which has the ID of a tooltip element, whose contents are updated whenever it is shown. So even if the association worked, it'd be wrong half the time :-)
Flags: needinfo?(gijskruitbosch+bugs)
Flags: qe-verify?
There should be a label, and after bug 1507365, we should be exposing that label, right Marco/Jamie?

(Also, I could have sworn there was a recent dupe of this bug, but I can't find it now)
Flags: needinfo?(mzehe)
Flags: needinfo?(jteh)
Heh, remarkable timing that you should ping me on this now. I just spotted this the other day and have been meaning to file a bug.

There is no label at all when the New Tab button is displayed inline in the tab strip:
https://searchfox.org/mozilla-central/source/browser/base/content/tabbrowser.xml#92

92              <xul:toolbarbutton class="tabs-newtab-button toolbarbutton-1"
93                                 anonid="tabs-newtab-button"
94                                 command="cmd_newNavigatorTab"
95                                 onclick="checkForMiddleClick(this, event);"
96                                 tooltip="dynamic-shortcut-tooltip"/>

so bug 1507365 doesn't fix this. This is essentially the same situation as bug 1480415 comment 3.

Note that there is also another New Tab button which can be displayed outside of the tab strip:
https://searchfox.org/mozilla-central/source/browser/base/content/browser.xul#780
From what I can gather, this is used if the New Tab button is moved such that it isn't adjacent to the tabs. This one *does* have a label:

                           label="&tabCmd.label;"

However, this isn't the button that gets used in the default configuration.
Flags: needinfo?(jteh)
Jamie has answered it all, clearing NI.
Flags: needinfo?(mzehe)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Summary: Open new tab button (and potentially various other buttons) has (have) no accessible name → Open new tab button has no accessible name
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a002d2b3408b
set tooltiptext for new tab button directly for a11y reasons, r=johannh
https://hg.mozilla.org/mozilla-central/rev/a002d2b3408b
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Flags: qe-verify? → qe-verify+

Hello,

I have reproduced this issue with 35.0a1 on Windows 10x64 with NVDA reader.

Confirming this issue as verified fixed on Windows 10x64 and macOS 10.12 on the last Beta 65.0b12 and latest Nightly 66.0a1 (2019-01-20)

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.