[Gaia icon] Some icons in gaia icon need to be updated to the latest version

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: arthurcc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

The following icons need to be updated to the latest version:

accessibility.svg
airplane.svg
battery.svg
bluetooth.svg
brightness.svg
browsing.svg
change-wallpaper.svg
developer.svg
device-info.svg
do-not-track.svg
download.svg
feedback.svg
find.svg
firefox.svg
gesture.svg
help.svg
homescreen.svg
info.svg
keyboard.svg
languages.svg
location.svg
lock.svg
media-storage.svg
messages.svg
moon.svg
network.svg
nfc.svg
notifications.svg
privacy.svg
sim-toolkit.svg
sim.svg
sound-max.svg
sound-min.svg
storage.svg
tethering.svg
tick-circle.svg
time.svg
usb.svg
wallpaper.svg
wifi.svg
Created attachment 8484884 [details]
SVGs.zip

Hi Arthur, the latest SVG icons has been attached, please help to update it. Thank you!
(In reply to Helen Huang from comment #1)
> Created attachment 8484884 [details]
> SVGs.zip
> 
> Hi Arthur, the latest SVG icons has been attached, please help to update it.
> Thank you!

I'm confused, the attached icons look identical to the icons we are already using [1]. Please could you clarify what has changed.

[1] http://gaia-components.github.io/gaia-icons/
Flags: needinfo?(hhuang)
Created attachment 8486231 [details]
Comparisons.png

Hi Wilson,

The most obvious thing is that USB icon and Device info icon are outdated, you can see Part A in the attachment. Those icons in 2.0 are correct, but it's been changed in v.2.1.

The others Settings icons only be slightly changed in v2.0, as I know, Carol made the changes that she mainly fixed blurry outline and size for those icons, however, I found the SVGs in Gaia-icon are not what we did, things like what I showed in Part B. Therefore, I would like to update SVGs again to make sure we use the latest files for Settings.

Please let me know if you have any question about the update, thank you.
Flags: needinfo?(hhuang)
VERSION STAMPED https://github.com/gaia-components/gaia-icons/releases/tag/v0.5.4
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Gaia-icons is now up to date, so we'll need another bug to now update Gaia (or we can re-open this bug to track the remaining work).
Helen, couple of questions:

1. Do we need duplicate 'battery' and 'wifi' icon when we already have a series of icons for each?
2. Why is the 'wifi' icon a different shape (more tulip) to the other wifi-1, wifi-2, etc icons (more triangular)
Flags: needinfo?(hhuang)
FYI you can see the new icons here: http://gaia-components.github.io/gaia-icons/
See Also: → bug 1064903
Created attachment 8487036 [details]
forward.svg

Hi Wilson, 

Thank you for your help. For the 'battery' and 'wifi' icon, I'm okay that using existing icon instead of them, don't need to duplicate. Also the 'network' icon could follow the same solution. I think the difference of the 'wifi' icons is caused by updating PNG icons to Settings and Status bar separately. Therefore, I would like to use the same one to keep those icons more consistent.

Besides, I found that the 'forward' icon needs to be updated as well. Could you help?
Flags: needinfo?(hhuang)
(In reply to Helen Huang from comment #8)
> Created attachment 8487036 [details]
> forward.svg
> 
> Hi Wilson, 
> 
> Thank you for your help. For the 'battery' and 'wifi' icon, I'm okay that
> using existing icon instead of them, don't need to duplicate. Also the
> 'network' icon could follow the same solution. I think the difference of the
> 'wifi' icons is caused by updating PNG icons to Settings and Status bar
> separately. Therefore, I would like to use the same one to keep those icons
> more consistent.

OK I will update bug 1064903 to use the existing 'wifi-4', 'battery-10' and 'signal-4' icons in the Settings app and remove the newly added 'wifi' and 'battery' icons from the gaia-icons font.

> Besides, I found that the 'forward' icon needs to be updated as well. Could
> you help?

Please open another issue to address this with relevant SVGs attached.
Got it! I'll open another bug for updating 'forward' icon.
Thanks.
You need to log in before you can comment on or make changes to this bug.