Closed Bug 1062168 Opened 8 years ago Closed 8 years ago

[Contacts] Not clearly Process when user does a search to set ICE contact,

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S5 (26sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: lolimartinezcr, Assigned: hola)

References

Details

Attachments

(1 file)

Flame
2.1
Gecko-6be7031
Gaia-e1f6d88

Pre-requisites:
1. Contacts saved.

STRs:
1.Tap contact application.
2. Tap settings.
3. Tap "Set ICE contacts".
4. Tap "Select ICE contact".
5. Tap search button.
6. Write some substring (substring of some contact)
7. Tap in result of search.

Actual result:
Contact is edited (but user doesn't know if this contact is selected), when presses "back" go back to result of search (but user doesn't know if this contact is selected) and after presses "Cancel" button.

I think this process is confuse for user and user has to do some steps not clearly for select a contact

Expected result:
Need info UX.

Expected result
QA Contact: lolimartinezcr
I agree with Loli, it's really confusing for the user, to be able to select a contact from the search result, I have to:
1. step 7, tap on the searched contact and enter in contact details
2. Press "<" button on the left to go back to the search screen
3. press cancel button to go back to the ICE Contact screen in settings
and only in that screen you realize that you have selected the searched contact

IMHO, after step 7 (tapping on the contact selected from the search) I would expect coming back to the ICE contacts screen in contact setting with the name of the selected contact already included in the IC1 or IC2 field.

Carrie, can you give us your feedback about this issue?
Francisco, do you think it's a feasible solution?

Thanks a lot!
Flags: needinfo?(francisco)
Flags: needinfo?(cawang)
[Blocking Requested - why for this release]: Annoying User experience, really confusing search flow from the ICE Contacts screen
blocking-b2g: --- → 2.1?
triage: bad user experience on the new feature
blocking-b2g: 2.1? → 2.1+
Well, those step were not intentionally set there. Are the result of a bug, IMHO, once we select from the search list we should select it.

Carrie what do you think?
Flags: needinfo?(francisco)
Yes the behavior is really weird.

After inputting the substring of a contact and we display the matched results on the list, user can then taps a result which means it's selected and then we go back to the ICE settings page and show the selected contact name in the field. This is the correct flow of the search function.
Thanks!
Flags: needinfo?(cawang)
I'll take a look at it.
Assignee: nobody → hola
Target Milestone: --- → 2.1 S5 (26sep)
Attached file Pull Request #23905
Fixed, but tests are missing. To test this, I suppose an integration test will be better, and since I'm having problems executing them I propose we open a follow up bug to make a test for this bug, so we can have the bug landed before friday.
Attachment #8490707 - Flags: review?(jmcf)
Comment on attachment 8490707 [details]
Pull Request #23905

thanks Adrian
Attachment #8490707 - Flags: review?(jmcf) → review+
landed in master:

https://github.com/mozilla-b2g/gaia/commit/85730dc68cf41e79126f8125cb48aab7153dbace
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Keywords: verifyme
Please request Gaia v2.1 approval on this when you get a chance.
Flags: needinfo?(hola)
Comment on attachment 8490707 [details]
Pull Request #23905

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): New Feature ICE Contacts
[User impact] if declined: High. User can lose context while interacting with the app
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low-risk patch
[String changes made]:
Attachment #8490707 - Flags: approval-gaia-v2.1?
Flags: needinfo?(hola)
Tested and working
Flame
User
2.2
Gecko: 45f4500
Gaia: d170091

Pending 2.1
Comment on attachment 8490707 [details]
Pull Request #23905

Ask for approval once the test from https://bugzilla.mozilla.org/show_bug.cgi?id=1062168#c7 is done.
Attachment #8490707 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1-
Comment on attachment 8490707 [details]
Pull Request #23905

Fabrice, now we have tests for this feature. See Bug 1069242 comment #6 

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): New Feature ICE Contacts
[User impact] if declined: High. User can lose context while interacting with the app
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low-risk patch
[String changes made]:
Attachment #8490707 - Flags: approval-gaia-v2.1- → approval-gaia-v2.1?
Attachment #8490707 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Tested and working
2.1
Flame
User
Gecko-5cf7098
Gaia-700f481
Status: RESOLVED → VERIFIED
Issue is verified fixed in Flame 2.2, 2.1 builds (Full Flash, nightly). 

Actual Results: Searching and selecting ICE contacts behaves correctly. 

Device: Flame Master
Build ID: 20141023040204
Gaia: 27a1d1baaa8e375b70e043efee67d5f2206c330b
Gecko: 88adcf8fef83
Version: 36.0a1 (Master)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Device: Flame 2.1
Build ID: 20141023001201
Gaia: 1e48e3e40e0780c0cd07a3457e5fe2efeeb542d1
Gecko: 09fb60a37850
Version: 34.0 (2.1)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
You need to log in before you can comment on or make changes to this bug.