Fix hardcoded strings in Messaging settings

RESOLVED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: tchevalier, Assigned: tchevalier)

Tracking

unspecified
2.1 S4 (12sep)
x86_64
Linux

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 fixed)

Details

Attachments

(5 attachments)

(Assignee)

Description

3 years ago
Created attachment 8483364 [details]
Flame 2.2

Two strings are displayed in English in Messaging settings:

"SIM settings" (Header)
"Info not available"

Attaching a PR to fix it. We already have the strings, just need to fix the template.
(Assignee)

Comment 1

3 years ago
Created attachment 8483367 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23668

Evelyn, if you could give a quick review to this one as well… Thanks! :)
Assignee: nobody → tchevalier
Status: NEW → ASSIGNED
Attachment #8483367 - Flags: review?(ehung)
(Assignee)

Updated

3 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Comment on attachment 8483367 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23668

oh man, we should really fix bug 928740 to avoid this kind of trivial issue happens again... anyway, thank you for taking care of this. :)
Attachment #8483367 - Flags: review?(ehung) → review+
(Assignee)

Comment 3

3 years ago
Unfortunately, not going to happen anytime soon, our best friend in the meantime is still Accented English :)

[Blocking Requested - why for this release]:

Two unlocalized strings in Messaging settings, bad user experience.
blocking-b2g: --- → 2.1?
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/f17f9a6bd846acb2c01777662bac8647a55f2102
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.2: affected → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S4 (12sep)
Théo, please set approval flag on the patch?
blocking-b2g: 2.1? → 2.1+
Flags: needinfo?(tchevalier)
(Assignee)

Comment 6

3 years ago
I got fooled by the string in HTML, the real string is "SIM {{index}} Settings", so right now it doesn't work, we need to give it the SIM number.

I'll attach a follow up PR (or I should open a follow up bug? But that sounds a lot of paperwork for such a trivial issue…)
Flags: needinfo?(tchevalier)
Note that due to recent policy changes, all patches need approval for uplift regardless of blocking status. Please request Gaia v2.1 approval on this patch when you get a chance. Sorry for the inconvenience :(
Flags: needinfo?(tchevalier)
(Assignee)

Comment 8

3 years ago
Created attachment 8484529 [details]
(follow up) Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23741/files

Follow up, the variable was not properly replaced because of a bad selector.

Tested on Flame 2.2, sorry I didn't catch that earlier :/

I'd say we can land this one on master then both on 2.1
Attachment #8484529 - Flags: review?(ehung)
Flags: needinfo?(tchevalier)
(Assignee)

Comment 9

3 years ago
Created attachment 8484531 [details]
Patched 2.2
(Assignee)

Comment 10

3 years ago
Comment on attachment 8483367 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23668

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1001285
[User impact] if declined: English strings in Messaging settings for all users
[Testing completed]: Tested on Flame device on 2.2
[Risk to taking this patch] (and alternatives if risky): very low
[String changes made]: none
Attachment #8483367 - Flags: approval-gaia-v2.1?
(Assignee)

Comment 11

3 years ago
Comment on attachment 8484529 [details]
(follow up) Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23741/files

[Approval Request Comment]
Same as for previous PR, follow up
Attachment #8484529 - Flags: approval-gaia-v2.1?

Updated

3 years ago
Attachment #8484529 - Flags: review?(ehung) → review+
(Assignee)

Comment 12

3 years ago
Thanks Evelyn, setting checkin-needed for the follow up
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/cfebf6a90fbdf687c876d4717169b72a86d0386a
Keywords: checkin-needed
Attachment #8483367 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Attachment #8484529 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
v2.1: https://github.com/mozilla-b2g/gaia/commit/0d8bf6d56287f9e192e6f11911e448e4955a3829
v2.1: https://github.com/mozilla-b2g/gaia/commit/75e26a51da368d4c81a02fd5c8198603f040d446
status-b2g-v2.1: affected → fixed
Duplicate of this bug: 1063429
Unable to verify this issue as we do not have SIM Card that has unknown SMSC state. This makes it impossible to verify the string "Info Not Available" is properly translated.
QA Whiteboard: [QAnalyst-Triage?][qanalyst-verify]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][qanalyst-verify] → [QAnalyst-Triage+][qanalyst-verify]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+][qanalyst-verify] → [QAnalyst-Triage+][QAnalyst-verify-]

Comment 17

3 years ago
Hi Josh,
This issue has been verified successfully on Flame2.1
See video: "verify_1062197.MP4".

Flame2.1 build:
Gaia-Rev        afdfa629be209dd53a1b7b6d6c95eab7077ffcd9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/dc3018cbdbe6
Build-ID        20141123001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141123.035029
FW-Date         Sun Nov 23 03:50:40 EST 2014
Bootloader      L1TC00011880
status-b2g-v2.1: fixed → verified

Comment 18

3 years ago
Created attachment 8527519 [details]
Verify Bug: verify_1062197.mp4
You need to log in before you can comment on or make changes to this bug.