a:hover doesn't work on tables with rowspan

VERIFIED DUPLICATE of bug 105268

Status

()

Core
Layout: Tables
VERIFIED DUPLICATE of bug 105268
17 years ago
17 years ago

People

(Reporter: Markus Dommann, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5+)
Gecko/20011022
BuildID:    2001102203

Links in a table cell that uses rowspan are drown with the wrong background
color when you move the mouse over the link and a:hover is set.

Reproducible: Always
Steps to Reproduce:
1. Load the example in Mozilla
2. Move the mouse over the links on the left
3. 

Actual Results:  background color of the links turns white

Expected Results:  background color should always stay the same

Example:

<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
  "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
  <head>
    <title></title>
    <style>
      a:link, a:visited, a:active
      { color:#00007F; text-decoration:none; font-weight:normal; }
      a:hover
      { color:#00007F; text-decoration:underline; font-weight:normal; }  
	  
      table.main
      { width:800px;
        vertical-align:middle; text-align:center;
        margin-left:auto; margin-right:auto;
        border-right: 1px solid #000000; }

      td.menu
      { background-color:#EDFAFE;
        width:160px;
        vertical-align:top; text-align:center;
        border:1px solid #00C0FF; }	
	</style>
  </head>
  <body>
    <table border="1" class="main">
      <tr> 
        <td rowspan="2" class="menu">
          <a href="../link1/">Link 1</a><br>
          <a href="../link2/">Link 2</a><br>
          <a href="../link3/">Link 3</a><br>
          <a href="../link4/">Link 4</a><br>
          <a href="../link5/">Link 5</a><br>
          <a href="../link6/">Link 6</a><br>
          <a href="../link7/">Link 7</a><br>		
        </td>
        <td>
          first row
        </td>
      </tr>
	  <tr>
        <td>second row</td>	  
	  </tr>
    </table>
  </body>
</html>
(Assignee)

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 105268 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
--> verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.