Pasting malformed HTML confuses Editor

VERIFIED WORKSFORME

Status

()

Core
Editor
P3
normal
VERIFIED WORKSFORME
17 years ago
15 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: kinmoz)

Tracking

Trunk
Future
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Using Build ID: 2001101103
Steps to reproduce problem:
1. Open the URL in navigator
2. Select All
3. Copy
4. Open a new editor document
5. Paste

Expected results: Same appearance as browser

Actual results: 1 and 3 are on the same line!

Addtional information:
This problem does not appear when editing a saved page.
This problem can also be reproduced using Insert HTML or HTML Source View.
Other examples of malformed HTML can be found on the Mozilla 0.9.5 release notes.

Comment 1

17 years ago
Confirmed. (BuildID: 2001100903)

When you see the bug click on "preview" and there is no bug here. Click back 
on "Normal" and ohhhh bug disapear.

dont the editor have to refresh the display ?
(Reporter)

Comment 2

17 years ago
Well spotted. In fact if you paste into any mode then that mode is corrupted
until you change mode. Unfortunately I originally encountered this in messenger
compose where this option is unavailable :-(
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla0.9.8
(Assignee)

Comment 3

17 years ago
--> 0.9.9 (Load balancing)
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0.1
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.0.1 → Future

Comment 4

15 years ago
neil, maybe i'm doing something wrong but, wfm 2003061908
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

15 years ago
Verified WFM on 1.5 trunk only.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.