Mozilla color display is corrupted when the System color bit depth is changed while Mozilla is running

VERIFIED DUPLICATE of bug 101843

Status

()

Core
Layout
VERIFIED DUPLICATE of bug 101843
17 years ago
12 years ago

People

(Reporter: Hans Habenicht, Assigned: Marc Attinasi)

Tracking

Trunk
PowerPC
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
When running mozilla 0.9.5 under MacOS 8.6 (After just doing a clean install
from the 8.6 disc that shipped with the computer (Blue & White G3-450), if I
switch the color depth from "Thousands" to "Millions", Mozilla's colors get all
messed up.  Sometimes the background of the web-page becomes black.  Other times
only the mozilla "frame" does strange things.  This happens with both the modern
theme, and the classic theme.

Comment 1

17 years ago
Well, I can confirm this happens. I ran Mac/2001101117 under OS 9.2.1 on a G4 in
24-bit color mode, and switched to 16-bit. Lo, seriously tweaked colors.

Guessing XPToolkit/Widgets. Will attach screenshot shortly. Marking OS=All.

There may be some relation to bug 57799, which is about responding to Appearance
Theme changes. I'm sure the OS sends some sort of color depth change event that
Mozilla simply isn't responding to here.
Status: UNCONFIRMED → NEW
Component: Themes → XP Toolkit/Widgets
Ever confirmed: true
OS: Mac System 8.6 → All
Summary: Mozilla 0.9.5 inverts colors when changing color depth on the fly → Mozilla color display is corrupted when the System color bit depth is changed

Comment 2

17 years ago
Created attachment 54718 [details]
Screenshot of a Mozilla Navigator window after System color bit depth was switched from Millions to Thousands.

Comment 3

17 years ago
I must say I'm rather surprised I can't find a duplicate of this. I'd be shocked
if this were only a recent problem.
Summary: Mozilla color display is corrupted when the System color bit depth is changed → Mozilla color display is corrupted when the System color bit depth is changed while Mozilla is running
(Reporter)

Comment 4

17 years ago
I've tested this on Win2k, using Mozilla 0.9.4, and was unable to duplicate the 
behavior.  I will re-test with Mozilla 0.9.5.

Comment 5

17 years ago
seems that background colors and borders are painting incorrectly. --> Layout
Assignee: hewitt → attinasi
Component: XP Toolkit/Widgets → Layout
QA Contact: pmac → petersen
(Reporter)

Comment 6

17 years ago
Could not duplicate the behavior on Win2k w/0.9.5, so it does not appear to be 
a regression issue, not does it appear to affect the win2k platform.

Comment 7

17 years ago
Be sure to note that display corruption affects the chrome, also.

Comment 8

17 years ago

*** This bug has been marked as a duplicate of 101843 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 9

17 years ago
*** Bug 109399 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.