Hamachi asserting on unknown touch type

RESOLVED FIXED in Firefox 34

Status

defect
P1
normal
RESOLVED FIXED
5 years ago
9 months ago

People

(Reporter: mchang, Assigned: mchang)

Tracking

unspecified
mozilla35
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(firefox33 wontfix, firefox34 fixed, firefox35 fixed, b2g-v2.1 fixed, b2g-v2.2 fixed)

Details

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #970751 +++

Since bug 970751, hamachi's are fatally asserting on an unknown touch type. 

The touch events we're asserting on are:

AMOTION_EVENT_ACTION_HOVER_EXIT
AMOTION_EVENT_ACTION_HOVER_ENTER
AMOTION_EVENT_ACTION_HOVER_MOVE
From https://bugzilla.mozilla.org/show_bug.cgi?id=970751#c151, patch to explicitly ignore touch hover events.
Attachment #8483620 - Flags: review?(mwu)
Attachment #8483620 - Flags: review?(mwu) → review+
Asking for 2.1 uplift approval, but I don't see the approval-2.1 flag in either Flags, Project Flags, or Tracking Flags. Hmph. 

[Feature/regressing bug #]: This is a regression caused by bug 970751 on hamachi devices only. Flames and nexus 4 are unaffected.
[User impact if declined]: Users running on a hamachi device will fatally assert, causing their devices to crash.
[Describe test coverage new/current, TBPL]: Manual testing to see what kind of touch events were causing the crash. I did scrolling, closing / open rocket bar, edge swipe between apps, logging into wifi, changing the developer ADB settings to devtools on a hamachi device.
[Risks and why]: Low - Before bug 970751, we were ignoring unknown touch events. With bug 970751, we were asserting that we saw an unknown touch event rather than ignoring it. With this patch, we explicitly ignore the set of touch events that we see on hamachi that were previously default ignored. 
[String Changes Made]: None
Comment on attachment 8483620 [details] [diff] [review]
bug 1062438 Fix Hamachi assertion regression

Approval Request Comment - see previous comment.
Attachment #8483620 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/7b8f40f9d13c
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Attachment #8483620 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.