[video/audio] When playing a video on Dailymotion, the video will display a black screen

RESOLVED FIXED in mozilla35

Status

()

Core
Audio/Video
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Petes, Assigned: mtseng)

Tracking

unspecified
mozilla35
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory], URL)

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8483645 [details]
dd.txt

Description:
When the user plays a video on Dailymotion, the video will display a black screen. The user only hears audio.


Repro Steps:
1) Update a Flame to 20140903000204
2) Go to dailymotion
3) Tap a video
4) Tap play
5) Tap share/allow


Actual:
black screen video playing 


Expected:
no black screen


Environmental Variables:
Device: Flame Master (319mb)
Build ID: 20140903000204
Gaia: fbb297c39aab5f17b179533d2a9a6c5166b2c197
Gecko: fb5e796da813
Version: 34.0a2 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency: 3/3, 100%
See attached: video clip, logcat, https://www.youtube.com/watch?v=nkCqsRlcrDQ
(Reporter)

Comment 1

3 years ago
This issue also reproduces on the Flame 2.1 (512mb), Open C 2.1, Flame 2.0 (319mb), Open C 2.0, Flame 1.4 (319mb), and the Open C 1.4. Black screen video playing, only hear audio.

Flame 2.1

Environmental Variables:
Device: Flame 2.1 (512mb)
Build ID: 20140903000204
Gaia: fbb297c39aab5f17b179533d2a9a6c5166b2c197
Gecko: fb5e796da813
Version: 34.0a2 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Open C 2.1

Environmental Variables:
Device: Open_C 2.1
Build ID: 20140903000204
Gaia: fbb297c39aab5f17b179533d2a9a6c5166b2c197
Gecko: fb5e796da813
Version: 34.0a2 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0

Environmental Variables:
Device: Flame 2.0 (319mb)
BuildID: 20140903000206
Gaia: 449d8db9b3ea1f9262db822c37ef2143477172b7
Gecko: 13b41e22c8f6
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open C 2.0

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140903000206
Gaia: 449d8db9b3ea1f9262db822c37ef2143477172b7
Gecko: 13b41e22c8f6
Version: 32.0 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 1.4

Environmental Variables:
Device: Flame 1.4 (319mb)
Build ID: 20140903063011
Gaia: 2ee5b00bfbb8a67a967094804390b4afce8ecf54
Gecko: f5a75c0dd74e
Version: 30.0 (1.4)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Open C 1.4

Environmental Variables:
Device: Open_C 1.4
Build ID: 20140903063011
Gaia: 2ee5b00bfbb8a67a967094804390b4afce8ecf54
Gecko: f5a75c0dd74e
Version: 30.0 (1.4)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(Reporter)

Comment 2

3 years ago
This issue also reproduces on the Flame 2.2 (319mb) and the Open C 2.2. Black screen video playing, only hear audio

Flame 2.2 (319mb)

Environmental Variables:
Device: Flame 2.2 Master (319mb)
BuildID: 20140903040203
Gaia: 52670853c17fc0d3d33065c667c0ce124c93b98f
Gecko: e58842c764dd
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Open C 2.2

Environmental Variables:
Device: Open_C 2.2 Master
BuildID: 20140903040203
Gaia: 52670853c17fc0d3d33065c667c0ce124c93b98f
Gecko: e58842c764dd
Version: 35.0a1 (2.2 Master)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
[Blocking Requested - why for this release]:

This is a popular website especially in France, I am going to nominate this 1.4? even though this is not a regression. This bug would affect many end users.
blocking-b2g: --- → 1.4?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
status-b2g-v2.2: --- → affected
Flags: needinfo?(ktucker)

Comment 4

3 years ago
Created attachment 8487106 [details]
IMG_1125.jpg

It looks like layout problem. When playing http://www.dailymotion.com/video/x25gxqo_the-boy-next-door-with-jennifer-lopez-official-trailer_shortfilms, you can see the bottom of the screen still display the video. Peter, can you take a look?
Flags: needinfo?(pchang)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]

Comment 5

3 years ago
Morris, please help to check the layer configuration for this video.
Flags: needinfo?(pchang) → needinfo?(mtseng)
Blocks: 1064847
No longer blocks: 1064847
(Assignee)

Comment 6

3 years ago
Created attachment 8489250 [details]
bug1062468-layertree.png

I found there is a huge black color layer (in my flame, 480x3428) on top of actual image layer which contains video frame. I'll figure out what this color layer is.
Flags: needinfo?(mtseng)
Morris,

If you have looked at this, can you suggest if this is very specific to this site or will it impact all sites using a certain format?
Flags: needinfo?(mtseng)
[Blocking Requested - why for this release]:

Pushing this back to 2.1 as the first suitable landing place. So far this is not considered a launch blocker by any partner.
blocking-b2g: 1.4? → 2.1?
QA Wanted - Does this problem happen on Firefox for Android?
blocking-b2g: 2.1? → backlog
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #9)
> QA Wanted - Does this problem happen on Firefox for Android?

Oh & backlog because it's a long standing issue.
(Assignee)

Comment 11

3 years ago
Wayne,

Sure, I'll update once I have some findings. Keep ni flag for reminder.
I tested this on my LG G2 Android device using Firefox OS for android ap.

When selecting 'play' the video went into full screen and only a black screen appeared, however the sound was still playing in the background with no video displayed.

The bug occurs on Firefox for Android.
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(jmitchell)
(Assignee)

Comment 13

3 years ago
Created attachment 8500316 [details]
index.html

Simple html file to reproduce this bug.
Assignee: nobody → mtseng
Status: NEW → ASSIGNED
Flags: needinfo?(mtseng)
(Assignee)

Comment 14

3 years ago
Created attachment 8500333 [details] [diff] [review]
bug1062468

I found if we have transform-style:preserve-3d property in parent element (see example file above) then the size would be wrong when entering full-screen mode. So we should reset this property to initial value when entering full-screen mode.
Attachment #8500333 - Flags: review?(bzbarsky)
Comment on attachment 8500333 [details] [diff] [review]
bug1062468

r=me

If this rule is covered by the fullscreen spec, worth raising a spec issue.
Attachment #8500333 - Flags: review?(bzbarsky) → review+
(Assignee)

Comment 16

3 years ago
https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=e8c8d1a65cdb

try run
(Assignee)

Comment 17

3 years ago
B2G emu debug mochitest 6 failed. But it looks like a known issue. So I think this patch is ready to check-in.
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/7ba191b165e4
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/7ba191b165e4
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.