When a temporary file is created from the download manager it should be readonly.

RESOLVED DUPLICATE of bug 1009465

Status

defect
--
critical
RESOLVED DUPLICATE of bug 1009465
5 years ago
3 years ago

People

(Reporter: mkmelin, Unassigned)

Tracking

({qawanted, regression})

Dependency tree / graph

Firefox Tracking Flags

(firefox32 affected, firefox33- affected, firefox34- affected, firefox35- affected, firefox-esr31- affected)

Details

+++ This bug was initially created as a clone of Bug #280419 +++

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910

When a download is requested and the user clicks 'Open' the file is saved in the
temporary folder. For word documents this allows users to edit and save the file
back to disk. When mozilla closes it will delete the temporary file, loosing the
changes.

The file should be marked readonly so the user can't change the file.

This is a particular problem with webmail.

Reproducible: Always

Steps to Reproduce:
1.Open a word document from the web by clicking the 'Open' button on the
download prompt.
2.Edit the document and select 'Save' from the 'File' menu in word.
3.Exit word.
4.Exit mozilla.

Actual Results:  
The file was deleted including the changes.

Expected Results:  
The temporary file should have been saved as readonly - so the user could not
modify the file. Ideally this would be done by removing the write permissions
for the file.

---

This was originally fixed in bug 280419, but has apparently regressed. I would guess in the Downloads.jsm work since I see this in ff31, but not thunderbird31 (which still use the old code)
[Tracking Requested - why for this release]:
Keywords: qawanted
[Tracking Requested - why for this release]: regression

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/43c0123f158b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130604 Firefox/24.0 ID:20130604141615
Bad:
http://hg.mozilla.org/mozilla-central/rev/22cb668fd727
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130604 Firefox/24.0 ID:20130604174517
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=43c0123f158b&tochange=22cb668fd727


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/ca43cd65708b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130604 Firefox/24.0 ID:20130604084416
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b6cce1e41253
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130604 Firefox/24.0 ID:20130604092414
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ca43cd65708b&tochange=b6cce1e41253

Regressed by:
b6cce1e41253	Monica Chew — Move execution from nsExternalAppHandler to nsDownload (b=858234, r=paolo)
The offending patch was backed out by Bug 916126 in Firefox ESR24 and Firefox25.0.
But not Firefox26+.

Progression window(beta)
Bad:
http://hg.mozilla.org/releases/mozilla-beta/rev/8b2c180a7b5d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 ID:20131010180222
Fixed:
http://hg.mozilla.org/releases/mozilla-beta/rev/f0c589ed7642
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 ID:20131015052812
Fixed pushlog:
http://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=8b2c180a7b5d&tochange=f0c589ed7642

Fixed un beta
5eede470990a	Monica Chew — Bug 916126: Backout changes to ExecuteDesiredAction only in the download manager (r=backout), a=akeybl, ba=gavin (no substantial IDL change)
Flags: needinfo?(mmc)
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(mmc)
Resolution: --- → DUPLICATE
Duplicate of bug: 1009465
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.