Closed Bug 1062571 Opened 6 years ago Closed 6 years ago

Keyboard is basically unusable with the new "alternative chars menu" UI

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified)

VERIFIED FIXED
blocking-b2g 2.2+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified

People

(Reporter: khuey, Assigned: rudyl)

References

Details

(Keywords: regression, Whiteboard: [p=1])

Attachments

(1 file)

[Blocking Requested - why for this release]:

idk what this feature is actually called but it's waaaaay too easy to trigger.  It's basically impossible for me to type an SMS without triggering it.
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
Kyle, could you please elaborate the issue you are facing?
You mean the 2-row "alternative char menu" when you long press a key or?

Thanks.
Flags: needinfo?(khuey)
Yes, that menu.  It feels like what's happening is that if I touch a second key before removing my finger from the first one the time spent on the first key "counts" towards opening the menu on the second.
Flags: needinfo?(khuey)
I'll take a look.
Thanks for filing this issue.

--
This should not block v2.1 release since this new design lives only in the master branch(v2.2).
Assignee: nobody → rlu
blocking-b2g: 2.1? → ---
Kyle,
If possible, please help confirm this won't happen on v2.1.
Thanks.
Flags: needinfo?(khuey)
I'm away from my desktop until 9/15 so I can't do a branch check.  If this feature landed in 2.2 then I'm confident that this is only an issue in 2.2.
Flags: needinfo?(khuey)
Summary: Keyboard is basically unusable with the new "uncommon characters" UI → Keyboard is basically unusable with the new "alternative chars menu" UI
Attached file Patch V1
[Root Cause]
Did not check this._currentMenuView instance availability in isMenuTarget(), so it caused JS error. 

---
Tim, could you please help review this simple patch?
Unit tests added to cover this part.
Attachment #8484893 - Flags: review?(timdream)
Status: NEW → ASSIGNED
Whiteboard: [p=1]
Comment on attachment 8484893 [details] [review]
Patch V1

Please mark the regression on Bugzilla and amend the commit message to something more meaningful.
Attachment #8484893 - Flags: review?(timdream) → review+
This is a regression caused by landing bug 934209.
Patch updated to address the review comments, will land it after CI passed.
Blocks: 934209
Keywords: regression
Landed to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/116ed6f6a85a87ef3c4d519f0c1c6df3b5e12068

--
Thanks for the review.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
I finally got a chance to update and this appears to have fixed it.  Thanks Rudy!
regression.
blocking-b2g: --- → 2.2?
Blocking 2.2+ for all fixed regressions.
blocking-b2g: 2.2? → 2.2+
Cannot verify this issue due to bug 1102135.
QA Whiteboard: [QAnalyst-Triage?]
Depends on: 1102135
Flags: needinfo?(ktucker)
Jeremiah, please verify this using the keyboard in the SMS app. The rocketbar issue should not block you from verifying this issue. Thanks
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(jlee)
No longer depends on: 1102135
Flags: needinfo?(jlee)
Issue is verified fixed on Flame 2.2.

Keyboard is usable with alternate characters UI. User must long press on letter for 1 second before alternate char UI appears.

Flame 2.2
Environmental Variables:
Device: Flame 2.2  (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141125040209
Gaia: 824a61cccec4c69be9a86ad5cb629a1f61fa142f
Gecko: acde07cb4e4d
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.