Firefox goes offline after page(s) refresh due to "DNS Cache" extension

RESOLVED WONTFIX

Status

()

Firefox
Extension Compatibility
--
major
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: Krystian, Unassigned)

Tracking

32 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.143 Safari/537.36

Steps to reproduce:

When I enter on every website (it doesn't matter - http:// or https:// - cause the same effect) and reload that website, Firefox goes offline.


Actual results:

Every page which was reload (manually by me or by the script reloading content on website) causes switching Firefox in offline mode. Because of that I cannot log into bank account panel manager or OVH panel etc., because I am randomly logged out.


Expected results:

Reloading pages shouldn't switch browser in offline mode. Before 32.0 version and actualization everything was OK.
(Reporter)

Updated

4 years ago
Severity: normal → major
(Reporter)

Updated

4 years ago
Summary: Firefox after page(s) refresh goes offline → Firefox goes offline after page(s) refresh
(Reporter)

Comment 1

4 years ago
(In reply to Krystian from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like
> Gecko) Chrome/36.0.1985.143 Safari/537.36

I've added this report from Google Chrome because Fx went offline mode. Proper User Agent is: Mozilla/5.0 (Windows NT 5.1; rv:32.0) Gecko/20100101 Firefox/32.0

Updated

4 years ago
Component: Untriaged → Document Navigation
Product: Firefox → Core
Krystian, do you see this in safe mode?
Flags: needinfo?(krozycki)
(Reporter)

Comment 3

4 years ago
(In reply to Boris Zbarsky [:bz] from comment #2)
> Krystian, do you see this in safe mode?

No, in safe mode that issue does not occur. I can insert list of my extensions and configuration changes.
Can you just try disabling your extensions one at a time until you find the one that causes this?
(Reporter)

Comment 5

4 years ago
(In reply to Boris Zbarsky [:bz] from comment #4)
> Can you just try disabling your extensions one at a time until you find the
> one that causes this?

Here's my list of extensions. I'll try to disable them (one by one) and check which one of them could make problems:

>
Informacje o aplikacji
----------------------

Nazwa: Firefox
Wersja: 32.0
Identyfikator programu: Mozilla/5.0 (Windows NT 5.1; rv:32.0) Gecko/20100101 Firefox/32.0

Zgłoszenia awarii z ostatnich 3 dni
-----------------------------------

ID zgłoszenia: bp-ef42e34f-08c4-4ed5-9142-b5e112140902
Data przesłania: 2 dni temu

Wszystkie zgłoszenia awarii

Rozszerzenia
------------

Nazwa: Add Bookmark Here ²
Wersja: 29.0.20140506
Włączone: true
ID: abhere2@moztw.org

Nazwa: CacheViewer
Wersja: 0.7.6
Włączone: true
ID: {71328583-3CA7-4809-B4BA-570A85818FBB}

Nazwa: Classic Theme Restorer
Wersja: 1.2.3
Włączone: true
ID: ClassicThemeRestorer@ArisT2Noia4dev

Nazwa: Color Management
Wersja: 0.5.3
Włączone: true
ID: color_management@seanhayes.name

Nazwa: CookieCuller
Wersja: 1.4
Włączone: true
ID: {99B98C2C-7274-45a3-A640-D9DF1A1C8460}

Nazwa: CSS Usage
Wersja: 0.3.3
Włączone: true
ID: csscoverage@spaghetticoder.org

Nazwa: DNS Cache
Wersja: 1.7
Włączone: true
ID: dnscache@dominik.jungowski

Nazwa: Download YouTube Videos as MP4
Wersja: 1.7.25
Włączone: true
ID: {b9bfaf1c-a63f-47cd-8b9a-29526ced9060}

Nazwa: DownThemAll!
Wersja: 2.0.17
Włączone: true
ID: {DDC359D1-844A-42a7-9AA1-88A850A938A8}

Nazwa: Firebug
Wersja: 2.0.3
Włączone: true
ID: firebug@software.joehewitt.com

Nazwa: Image Zoom
Wersja: 0.6.3
Włączone: true
ID: {1A2D0EC4-75F5-4c91-89C4-3656F6E44B68}

Nazwa: Lazarus: Form Recovery
Wersja: 2.3
Włączone: true
ID: lazarus@interclue.com

Nazwa: Leet Key
Wersja: 1.4.3
Włączone: true
ID: {3335F91D-2AEF-4097-B831-C96C60349822}

Nazwa: MeasureIt
Wersja: 0.4.13
Włączone: true
ID: {75CEEE46-9B64-46f8-94BF-54012DE155F0}

Nazwa: NoScript
Wersja: 2.6.8.40rc2
Włączone: true
ID: {73a6fe31-595d-460b-a920-fcc0f8843232}

Nazwa: Open Profile Folder
Wersja: 1.3.3
Włączone: true
ID: {a756d17a-5a4c-4417-813c-c8cd0151e486}

Nazwa: Password Exporter
Wersja: 1.2.1
Włączone: true
ID: {B17C1C5A-04B1-11DB-9804-B622A1EF5492}

Nazwa: ReloadEvery
Wersja: 28.0.2
Włączone: true
ID: {888d99e7-e8b5-46a3-851e-1ec45da1e644}

Nazwa: Restart Firefox
Wersja: 0.5
Włączone: true
ID: restart@restart.org

Nazwa: Screengrab (fix version)
Wersja: 0.98.01c
Włączone: true
ID: {02450914-cdd9-410f-b1da-db004e18c671}

Nazwa: Server Spy
Wersja: 0.2.3
Włączone: true
ID: ServerSpy@jacquet.eu.org

Nazwa: Session Manager
Wersja: 0.8.1.5
Włączone: true
ID: {1280606b-2510-4fe0-97ef-9b5a22eafe30}

Nazwa: Status-4-Evar
Wersja: 2014.07.06.05
Włączone: true
ID: status4evar@caligonstudios.com

Nazwa: Table2Clipboard
Wersja: 1.5.3.1
Włączone: true
ID: {9ab67d74-ec41-4cb2-b417-df5d93ba1beb}

Nazwa: Tweak Network
Wersja: 1.8
Włączone: true
ID: {DAD0F81A-CF67-4eed-98D6-26F6E47274CA}

Nazwa: View Cookies
Wersja: 1.12
Włączone: true
ID: {8F6A6FD9-0619-459f-B9D0-81DE065D4E21}

Nazwa: Vividas player plugin
Wersja: 4.1.3
Włączone: true
ID: player@vividas.com

Nazwa: Work Offline
Wersja: 2.2
Włączone: true
ID: {761a54f1-8ccf-4112-9e48-dbf72adf6244}

Nazwa: Bitdefender QuickScan
Wersja: 0.9.9.142
Włączone: false
ID: {e001c731-5e37-4538-a5cb-8168736a2360}

Nazwa: Firefox Synchronisation Extension
Wersja: 1.7.110.333
Włączone: false
ID: fe_3.6@nokia.com

Nazwa: Microsoft .NET Framework Assistant
Wersja: 0.0.0
Włączone: false
ID: {20a82645-c095-46ed-80e3-08825760534b}

Nazwa: Paste to Tab and Go
Wersja: 0.9.1
Włączone: false
ID: pastetotab@loucypher

Nazwa: PC Sync 2 Synchronisation Extension
Wersja: 1.0.0.749
Włączone: false
ID: bkmrksync@nokia.com

Nazwa: PDF Download
Wersja: 3.0.0.2
Włączone: false
ID: {37E4D8EA-8BDA-4831-8EA1-89053939A250}

Nazwa: ShowIP
Wersja: 2.5
Włączone: false
ID: {3e9bb2a7-62ca-4efa-a4e6-f6f6168a652d}

Nazwa: Widevine Media Optimizer
Wersja: 6.0.0.12757
Włączone: false
ID: {2d3fbcf7-be69-4433-8858-c621a8d0e58d}

Grafika
-------

Data sterownika: 2-28-2011
GPU #2 Active: false
ID dostawcy: 0x8086
ID urządzenia: 0x2e12
Okna ze sprzętowym przyspieszeniem grafiki: 1/1 Direct3D 9
Opis adaptera: Intel(R) Q45/Q43 Express Chipset
RAM adaptera: Unknown
Renderer WebGL: Google Inc. -- ANGLE (Intel(R) Q45/Q43 Express Chipset Direct3D9 vs_3_0 ps_3_0)
Sterowniki adaptera: igxprd32
Wersja sterownika: 6.14.10.5338
windowLayerManagerRemote: false
Włączone DirectWrite: false (0.0.0.0)
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Ważne zmodyfikowane ustawienia
------------------------------

accessibility.typeaheadfind.casesensitive: 1
accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size_cached_value: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 2
browser.cache.memory.capacity: -1
browser.history_expire_days.mirror: 999
browser.places.importBookmarksHTML: false
browser.places.smartBookmarksVersion: 7
browser.search.param.yahoo-fr: chr-greentree_ff&type=971163
browser.search.suggest.enabled: false
browser.search.useDBForOrder: true
browser.sessionstore.upgradeBackup.latestBuildID: 20140825202822
browser.startup.homepage: about:blank
browser.startup.homepage_override.buildID: 20140825202822
browser.startup.homepage_override.mstone: 32.0
browser.tabs.drawInTitlebar: false
browser.tabs.insertRelatedAfterCurrent: false
browser.urlbar.maxRichResults: 8
browser.urlbar.trimURLs: false
dom.max_chrome_script_run_time: 40
dom.max_script_run_time: 0
dom.mozApps.used: true
dom.w3c_touch_events.expose: false
extensions.lastAppVersion: 32.0
font.internaluseonly.changed: true
general.useragent.extra.microsoftdotnet: ( .NET4.0C)
gfx.color_management.mode: 1
gfx.color_management.rendering_intent: 3
network.cookie.prefsMigrated: true
network.dns.disablePrefetch: true
network.dnsCacheEntries: 0
network.dnsCacheExpiration: 0
network.http.max-connections: 40
network.http.max-connections-per-server: 16
network.http.max-persistent-connections-per-proxy: 16
network.http.max-persistent-connections-per-server: 16
network.http.pipelining: true
network.http.pipelining.maxrequests: 8
network.http.proxy.pipelining: true
places.database.lastMaintenance: 1409847421
places.history.expiration.transient_current_max_pages: 92175
places.history.expiration.transient_optimal_database_size: 147478446
places.last_vacuum: 1332175715
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.expose_full_path: true
plugin.importedState: true
print.extend_native_print_dialog: false
privacy.clearOnShutdown.cache: false
privacy.clearOnShutdown.cookies: false
privacy.clearOnShutdown.downloads: false
privacy.clearOnShutdown.extensions-dta: true
privacy.clearOnShutdown.formdata: false
privacy.clearOnShutdown.history: false
privacy.clearOnShutdown.sessions: false
privacy.cpd.downloads: false
privacy.cpd.extensions-dta: true
privacy.cpd.extensions-sessionmanager: false
privacy.cpd.formdata: false
privacy.cpd.history: false
privacy.cpd.siteSettings: true
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.timeSpan: 4
security.disable_button.openCertManager: false
security.remember_cert_checkbox_default_setting: false
security.warn_viewing_mixed.show_once: false
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1407883409

JavaScript
----------

Przyrostowy GC: true

Ułatwienia dostępu
------------------

Aktywne: false
Zablokuj ułatwienia dostępu: 0

Wersje bibliotek
----------------

NSPR
Oczekiwana wersja minimalna: 4.10.6
Wersja w użyciu: 4.10.6

NSS
Oczekiwana wersja minimalna: 3.16.4 Basic ECC
Wersja w użyciu: 3.16.4 Basic ECC

NSSSMIME
Oczekiwana wersja minimalna: 3.16.4 Basic ECC
Wersja w użyciu: 3.16.4 Basic ECC

NSSSSL
Oczekiwana wersja minimalna: 3.16.4 Basic ECC
Wersja w użyciu: 3.16.4 Basic ECC

NSSUTIL
Oczekiwana wersja minimalna: 3.16.4
Wersja w użyciu: 3.16.4
(Reporter)

Comment 6

4 years ago
OK. I've found the guilty. DNS Cache (the latest version - 1.7) turns the Firefox in offline mode. When I've disabled that extension Firefox started to work properly.
OK.  Sounds like this is either a bug in the extension or at least something to talk about with the extension author....
Component: Document Navigation → Extension Compatibility
Flags: needinfo?(krozycki)
Product: Core → Firefox
Summary: Firefox goes offline after page(s) refresh → Firefox goes offline after page(s) refresh due to "DNS Cache" extension
The add-on hasn't been updated in almost 3 years, so I don't expect it to be updated for the changes in 32. I'll mark it as incompatible and downgrade it on the site. I'll also notify the developers, just in case they are interested in keeping the add-on going.

There's nothing more to do here, I think.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 9

4 years ago
(In reply to Jorge Villalobos [:jorgev] from comment #8)
> There's nothing more to do here, I think.

So do I. I agree. It seems fine for me. Bug report may be closed.
Duplicate of this bug: 1063003
You need to log in before you can comment on or make changes to this bug.