[Dialer][Audio Channel] While receiving a call the audio only comes out the front speaker

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: jschmitt, Unassigned)

Tracking

({regression})

unspecified
2.1 S7 (24Oct)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 fixed, b2g-v2.2 fixed)

Details

()

Attachments

(1 attachment)

Reporter

Description

5 years ago
Posted file log.txt
Description:
While reciving a phone call the audio plays through the front speaker and not the back speaker.
   
Repro Steps:
1) Update a Flame device to BuildID: 20140903040203
2) WIth another device call the DUT
3) Do not answer the phone
  
Actual:
The audio plays through the front speaker only.
  
Expected: 
The audio plays through the back speaker not the front speaker.
  
Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140903040203
Gaia: 52670853c17fc0d3d33065c667c0ce124c93b98f
Gecko: e58842c764dd
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
  
Notes:
Repro frequency: 100%
See attached: logcat
Reporter

Comment 1

5 years ago
Issue does not occur on 2.1 Flame 319MB

Environmental Variables:
Device: Flame 2.1
BuildID: 20140903000204
Gaia: fbb297c39aab5f17b179533d2a9a6c5166b2c197
Gecko: fb5e796da813
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
Reporter

Comment 2

5 years ago
I have uploaded a video of this issue.

https://www.youtube.com/watch?v=pEey4gMHQzA
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Reporter

Updated

5 years ago
Summary: [Dialer][Audio Channel] While reciving a call the audio only comes out the front speaker → [Dialer][Audio Channel] While receiving a call the audio only comes out the front speaker
[Blocking Requested - why for this release]:
Functional regression of a core feature.  Ringing becomes difficult to hear when the audio channel switches.  Don't have a 2.2? option yet.

Requesting a window.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: ychung
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame Master
BuildID: 20140902113703 
Gaia: 7e469783859785a8bd4bf02a802f32561c84be7b
Gecko: 1d3b0ec6e32d
Version: 35.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken Environmental Variables:
Device: Flame Master
BuildID: 20140902122901 
Gaia: 271c527d57c845e0c38b42deed91e8a89a137f1a
Gecko: a73392bff404
Version: 35.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Gaia: 7e469783859785a8bd4bf02a802f32561c84be7b
Gecko: a73392bff404

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 271c527d57c845e0c38b42deed91e8a89a137f1a
Gecko: 1d3b0ec6e32d

https://github.com/mozilla-b2g/gaia/compare/7e469783859785a8bd4bf02a802f32561c84be7b...271c527d57c845e0c38b42deed91e8a89a137f1a

Possibly caused by Bug 1061012
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Possibly broken by bug 1061012 - can you take a look Etienne?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(etienne)
(In reply to Joshua Mitchell [:Joshua_M] from comment #5)
> Possibly broken by bug 1061012 - can you take a look Etienne?

If this broke when bug 1061012 landed it probably means it worked by mistake :) (the callscreen was considered visible when it shouldn't have).

Alexandre, you know the "visible-audio-channel-changed" mozChromeEvent mess better than I do, any ideas?
Flags: needinfo?(etienne) → needinfo?(lissyx+mozillians)
I have no idea besides that I received calls on my Nexus S with bug 1061012 landed and had no issue.
Flags: needinfo?(lissyx+mozillians)
blocking-b2g: --- → 2.2?
The regressing patch landed on 2.1 now. Can we see if this happens there post landing?
QA Whiteboard: [QAnalyst-Triage+]
Keywords: qawanted

Comment 9

5 years ago
This bug is fixed for me on my Flame in master (v2.2)
Certainly thanks to this commit https://github.com/mozilla-b2g/gaia/commit/ea5b934ef52990275d1f145febd906427240f308. 
This bug was probably linked to this one : https://bugzilla.mozilla.org/show_bug.cgi?id=1065147
QA-Wanted to check in the latest 2.1 and 2.2
Reporter

Comment 11

5 years ago
Issue DOES repro on 2.1 Flame 319MB KK build.

Issue does NOT repro on 2.2 Flame 319 KK build.

Environmental Variables:
Device: Flame 2.1
BuildID: 20140922053548
Gaia: 689c4ad4d8c3e4aa95805a2e49ae6cf786a1ae91
Gecko: 185fc54d29c1
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140922040649
Gaia: 3802009e1ab6c3ddfc3eb15522e3140a96b33336
Gecko: 5e704397529b
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
MArking 2.2 as fixed based on comment 11 and comment 9

Marking 2.1 as affected based on comment 11 and comment 8
Flags: needinfo?(jmitchell)
QA Contact: ychung

Comment 13

5 years ago
should we merge back to v2.1?
blocking-b2g: 2.2? → 2.2+
Keywords: verifyme
It can not be reproduced in latest 2.1 Keon. Seems that this bug has been fixed :) So marking as resolved.

Environmental Variables:
Device: Keon V2.1
BuildID: 20141008125311
Gaia: d71f8804
Gecko: f4d4a81
Version: 34.0a2
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: verifyme
Resolution: --- → WORKSFORME
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]

Updated

4 years ago
Target Milestone: --- → 2.1 S7 (24Oct)
You need to log in before you can comment on or make changes to this bug.