Closed Bug 10626 Opened 20 years ago Closed 20 years ago

save wallet info dialog displaying Japanese???

Categories

(Toolkit :: Form Manager, defect, P3, blocker)

x86
Linux
defect

Tracking

()

CLOSED DUPLICATE of bug 10423

People

(Reporter: jay, Assigned: morse)

Details

The dialog the follows clicking "SAVE" from the enter wallet contents page is in
japanese and the "OK" button does not work

Steps:
1. Edit | Wallet | Samples
2. Goto the page where you can enter your wallet information.
3. Fill in name, click "SAVE" at the bottom of the page
4. Observe the wacky behavior of the dialog box.

Build:
Linux RH 6 build 1999072711
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
I assume you are being sarcastic when you said it was displaying Japanese --
rather it is displaying abreviated message strings with many embedded periods.
If that's what you meant, then this is a duplicate of 10423 and I'm marking it
as such.  If you weren't being sarcastic and it really was in Japanese, then we
have some other problem and you should reopen this report.

*** This bug has been marked as a duplicate of 10423 ***
Status: RESOLVED → REOPENED
I was NOT being sarcastic...the dialog box does contain what seems to be
Japanese characters or some other language with similar types of characters.  If
you cannot reproduce this, i can show you on my machine.
Sorry, forgot to reopen the bug...
Last night I checked in a fix for 10423.  The problem was that uninitialized
memory was being put into the localized string.  It was appearing as embedded
periods on my test but could just as easily have been anything else
(e.g., Japanese characters) depending what was in that uninitialized memory.

So could you try this out again with todays builds and see if you are still
seeing the problem.  If not, then close it out as a dup of 10423, which I'm
pretty sure it is.
Resolution: DUPLICATE → ---
Clearing Duplicate resolution due to Reopen.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Resolving and Verifying as Dup of Bug 10423... which seems "fixed" with Linux
build 1999072813

*** This bug has been marked as a duplicate of 10423 ***
Status: VERIFIED → CLOSED
Product: Core → Toolkit
QA Contact: paulmac → form.manager
You need to log in before you can comment on or make changes to this bug.