Closed Bug 1062617 Opened 5 years ago Closed 3 years ago

DevTools: Style Editor Import button should Open a Dialog box which defaults to CSS files

Categories

(DevTools :: Style Editor, defect, P3)

35 Branch
defect

Tracking

(firefox49 fixed)

RESOLVED FIXED
Firefox 49
Tracking Status
firefox49 --- fixed

People

(Reporter: sys.sgx, Assigned: tephra)

Details

(Whiteboard: [good first bug][lang=js])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20140903072057

Steps to reproduce:

Open DevTools Style Editor, and then click on the Import button. The OS dialog box that opens, should be allowed by default to select only files with the extension of css.
Component: Untriaged → Developer Tools: Style Editor
OS: Windows 7 → All
Hardware: x86 → All
I am able to reproduce the bug reported above: the OS dialog box that opens lists all files, not only the ones with extension css.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Whiteboard: [good first bug][lang=js]
Attached patch Patch v1Splinter Review
First contribution to devtools. Seems like we called the wrong function here and should have called appendFilters instead of appendFilter.

Not sure who to tag to review this any help with that?

// Eric
Thanks for your contribution Eric.
Not sure who knows the file picker API to review this change. I have never used it.
I think maybe Mike might know more about this.
Attachment #8747476 - Flags: review?(mratcliffe)
Comment on attachment 8747476 [details] [diff] [review]
Patch v1

Review of attachment 8747476 [details] [diff] [review]:
-----------------------------------------------------------------

(In reply to eric from comment #2)
> Created attachment 8747476 [details] [diff] [review]
> Patch v1
> 
> First contribution to devtools. Seems like we called the wrong function here
> and should have called appendFilters instead of appendFilter.
> 
> Not sure who to tag to review this any help with that?
> 
> // Eric

We should have called appendFilter instead of appendFilters, which is what your patch does.

Great work! It is much appreciated.
Attachment #8747476 - Flags: review?(mratcliffe) → review+
(In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #4)
> Comment on attachment 8747476 [details] [diff] [review]
> Patch v1
> 
> Review of attachment 8747476 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> (In reply to eric from comment #2)
> > Created attachment 8747476 [details] [diff] [review]
> > Patch v1
> > 
> > First contribution to devtools. Seems like we called the wrong function here
> > and should have called appendFilters instead of appendFilter.
> > 
> > Not sure who to tag to review this any help with that?
> > 
> > // Eric
> 
> We should have called appendFilter instead of appendFilters, which is what
> your patch does.
> 
> Great work! It is much appreciated.

Thanks Michael!

It's been a while since my last contribution to firefox so correct me if I'm wrong.
This needs to get pushed to the try-server before adding the checkin needed flag right?

// Eric
Flags: needinfo?(mratcliffe)
Yes, and to push to try you would need Level 1 Commit Access, but we normally wait for you to submit a few patches first.

Would you like me to push this to try?
Flags: needinfo?(mratcliffe)
(In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #6)
> Yes, and to push to try you would need Level 1 Commit Access, but we
> normally wait for you to submit a few patches first.
> 
> Would you like me to push this to try?

Yeah that would be great thanks!
This passes on try, marking as checkin-needed.
Keywords: checkin-needed
(In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #9)
> This passes on try, marking as checkin-needed.

Thanks Michael, had some work stuff over the weekend and haven't had time to
mark it yet!

Thanks for the help on this bug :)
This originally had the wrong bug number (102617), I backed that out and relanded it with the right number in https://hg.mozilla.org/integration/fx-team/rev/3bc242e75155
https://hg.mozilla.org/mozilla-central/rev/3bc242e75155
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 49
I have reproduced this bug with Nightly 35.0a1(2014-09-03) on Windows 10, 64 bit!

The Bug's fix is now verified on Beta 49.0b1.

Build ID 	20160802125918
User Agent 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

[bugday-20160803]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.