Pseudo :first-line doesn't work properly when added after the element is already rendered

RESOLVED DUPLICATE of bug 145419

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 145419
3 years ago
3 years ago

People

(Reporter: Evan Washkow, Unassigned)

Tracking

({reproducible, testcase})

32 Branch
reproducible, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8483854 [details]
first-line bug.PNG

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.102 Safari/537.36

Steps to reproduce:

1) Go to http://benhowdle.im/cssselectors/
2) Select "first-line" (left-hand menu)


Actual results:

The first line of <p> tags don't change to green.

As you can see in the attached screenshot, Firebox (in Firefox) is showing that the green *should* be applying, however, it's not.


Expected results:

The first line of <p> tags should change to green.

There's a way to force Firefox to color the first line green:
1) Add an element style to the <p> tag
2) Change the <p> to display: block -- notice that this does *not* fix the issue
3) Change the <p> to display: inline-block -- this fixes the issue (the first line is now green)
4) Change the <p> back to display: block -- the first line remains green.
(Reporter)

Updated

3 years ago
Summary: Psuedo :first-line doesn't work properly → Pseudo :first-line doesn't work properly
Status: UNCONFIRMED → NEW
Component: Untriaged → CSS Parsing and Computation
Ever confirmed: true
Keywords: reproducible, testcase
OS: Windows 7 → All
Product: Firefox → Core
Hardware: x86_64 → All
This is also broken on Nightly. Not sure if this is css computation or layout (esp. considering switching display: about fixes things), but leaving this here for now.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 145419
Summary: Pseudo :first-line doesn't work properly → Pseudo :first-line doesn't work properly when added after the element is already rendered
You need to log in before you can comment on or make changes to this bug.