[Contacts] Data from Facebook synced contacts stays after sync is disabled

RESOLVED DUPLICATE of bug 1060101

Status

Firefox OS
Gaia::Contacts
RESOLVED DUPLICATE of bug 1060101
4 years ago
4 years ago

People

(Reporter: RJ, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8483856 [details]
ContactLog.txt

Description:
After having facebook friends synced as contacts, then disabling facebook friends sync, the contacts app will leave the contacts picture and name in the app(any other apps that display contacts will not show these contacts as contacts) until app is forced closed.  


Repro Steps:
1) Update a Flame to Build: 20140903000204
2) Open contacts app and go to the settings 
3) Toggle sync Facebook friends button on
4) Sign in with a valid account and import some contacts 
5) Toggle sync Facebook friends button off


Actual:
Pictures and names of facebook contacts are preserved, but when tapped nothing happens until contact app is force closed  


Expected:
All data of facebook contacts are removed 

Environmental Variables:
Device: Flame Master (319mb)
Build ID: 20140903000204
Gaia: fbb297c39aab5f17b179533d2a9a6c5166b2c197
Gecko: fb5e796da813
Version: 34.0a2 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency:100%
See attached:video clip, logcat,
http://youtu.be/gehVQjcpNJY
(Reporter)

Comment 1

4 years ago
This issue DOES occur on Flame 2.2 (319mb), Flame 2.1(512mb) 

Facebook friend data is not removed when sync is disabled 

Flame Master

Environmental Variables:
Device: Flame Master (319mb)
BuildID: 20140903040203
Gaia: 52670853c17fc0d3d33065c667c0ce124c93b98f
Gecko: e58842c764dd
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1

Environmental Variables:
Device: Flame Master (512mb)
BuildID: 20140902040205
Gaia: 44bf2e3bc5ddea9db9a8c851bd353cb234aa883c
Gecko: c360f3d1c00d
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Issue does NOT occur in Open C 2.1, Flame 2.0(319mb), and Open C 2.0

All data of facebook contacts are removed 


Open C 2.1

Environmental Variables:
Device: Open_C 2.1
Build ID: 20140903000204
Gaia: fbb297c39aab5f17b179533d2a9a6c5166b2c197
Gecko: fb5e796da813
Version: 34.0a2 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Flame 2.0

Environmental Variables:
Device: Flame 2.0
BuildID: 20140903000206
Gaia: 449d8db9b3ea1f9262db822c37ef2143477172b7
Gecko: 13b41e22c8f6
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Open_C 2.0

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140903000206
Gaia: 449d8db9b3ea1f9262db822c37ef2143477172b7
Gecko: 13b41e22c8f6
Version: 32.0 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]:

This is a regression from 2.0 and this will confuse and frustrate the end user. All Facebook data should be removed when selected to do so by the user. Nominating this 2.1?
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
status-b2g-v2.2: --- → affected
Flags: needinfo?(ktucker) → needinfo?(rmitchell)
Keywords: regressionwindow-wanted
2.1 is no longer master which you stated twice. Please correct. Also, can we recheck Open C 2.1? That doesn't make sense to me that the issue does not occur.
triage: identifiable regression. note that there's no "import" function to get FB contact here.
blocking-b2g: 2.1? → 2.1+
(Reporter)

Comment 5

4 years ago
This issue does occur on Open C 2.1, there is an instance where disabling sync will remove contacts and launch facebook, leaving it on an endless loading screen stating "logging out of facebook" in which user must force closing contacts app, this has a low rate of occurrence though
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
Flags: needinfo?(rmitchell) → needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+]

Updated

4 years ago
QA Contact: ddixon
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1060101
issue is resolved - removing keywords
blocking-b2g: 2.1+ → ---
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.