'module' object has no attribute 'wireprotocommand' error when trying to import reviewboard extension

RESOLVED WORKSFORME

Status

MozReview
General
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: botond, Unassigned)

Tracking

Production

Details

(Reporter)

Description

4 years ago
Not sure if this is the right component for this bug, but after enabling the |reviewboard| extension via |mach mercurial-setup|, I get the following error every time I run an hg command:

*** failed to import extension reviewboard from /home/botond/.mozbuild/version-control-tools/hgext/reviewboard/client.py: 'module' object has no attribute 'wireprotocommand'
abort: No module named exchange!

(Note: I have the same issue with 'firefoxtree', but not with 'bzpost' or 'bzexport'.)
(Reporter)

Comment 1

4 years ago
(In reply to Botond Ballo [:botond] from comment #0)
> (Note: I have the same issue with 'firefoxtree', but not with 'bzpost' or
> 'bzexport'.)

Er, sorry, I *am* having an issue with 'bzpost': the second line, 'abort: No module named exchange' seems to be caused by that, not by 'reviewboard'.

Comment 2

4 years ago
Upgrade to Mercurial 3.0+ and reopen if that doesn't work.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

4 years ago
(In reply to Gregory Szorc [:gps] (away Sep 10 through 27) from comment #2)
> Upgrade to Mercurial 3.0+ and reopen if that doesn't work.

Heh. I had upgraded to 3.1 prior to installing the extensions, but the shell where I was actually trying the extensions still had 2.7 in the PATH. Sorry for the noise.
(Assignee)

Updated

3 years ago
Product: bugzilla.mozilla.org → Developer Services
(Assignee)

Updated

2 years ago
Product: Developer Services → MozReview
You need to log in before you can comment on or make changes to this bug.