www.nvidia.com causes download attempt instead of displaying

VERIFIED DUPLICATE of bug 11133

Status

()

Core
Networking
P3
normal
VERIFIED DUPLICATE of bug 11133
19 years ago
a year ago

People

(Reporter: tor, Assigned: rpotts (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Overview Description:

On a necko build of mozilla, attempting to visit the page at www.nvidia.com
results in a download attempt instead of displaying the page in the browser.

Steps to Reproduce:
1) start apprunner
2) type "http://www.nvidia.com/" in the URL bar

  Also:

1) "./apprunner http://www.nvidia.com/"

Actual Results:

A small dialog saying "You have started to download a file of type text/html
..."

Expected Results:

The webpage displayed in the browser.

Build Date & Platform Bug Found:

July 27th CVS pull from about 4pm PST.  Solaris/native build.

Comment 1

19 years ago
Gags, this happens at quite a few sites, let me know if you need more test
cases.

Updated

19 years ago
OS: Solaris → All
Hardware: Sun → All

Comment 2

19 years ago
I think the problem may be the charset attribute of the Content-type header line
sent by their HTTP server. It returns: Content-Type: text/html; charset=US-ASCII

and in the xterm window where I launched apprunner the following message
appears:
DocLoaderFactory: Unable to create ContentViewer for command=view,
content-type=text/html; charset=US-ASCII

Tested on Linux (RH 6.0) build 1999073108

FYI:
$ telnet www.nvidia.com 80
Trying 140.174.105.248...
Connected to www.nvidia.com.
Escape character is '^]'.
HEAD / HTTP/1.0

HTTP/1.1 200 OK
Server: Lotus-Domino/Release
Date: Mon, 02 Aug 1999 11:43:05 GMT
Connection: Close
Content-Base: http://notesweb1.nvidia.com/Home.nsf
Content-Type: text/html; charset=US-ASCII
Content-Length: 20914
Last-Modified: Tue, 27 Jul 1999 09:01:03 GMT
Expires: Tue, 27 Jul 1999 09:01:03 GMT

Connection closed by foreign host.

Updated

19 years ago
Target Milestone: M9

Comment 3

19 years ago
*** Bug 10764 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Assignee: gagan → rpotts

Comment 4

19 years ago
Rick was looking at this one.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

19 years ago
*** This bug has been marked as a duplicate of 11133 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
You need to log in before you can comment on or make changes to this bug.