empty page reload removes tabs

RESOLVED WORKSFORME

Status

SeaMonkey
Tabbed Browser
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Willi Wurzer, Assigned: jag (Peter Annema))

Tracking

Trunk
Future
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012
BuildID:    2001101202

i tried to load a page in a new tab whose dns could not be resolved, resulting
in an empty tab. i tried again by rigtmouse+reload causing all open tabs to
disappear.

Reproducible: Didn't try

Comment 1

17 years ago
Confirmed with Linux CVS. Attaching a simple testcase. Steps to reproduce:

a) start a browser window and open two or three webs in different tabs.
b) open the attached file in a new tab, a popup will tell you that the page
couldn't be found, but the tab was created anyway.
c) go to the empty tab, right click and reload frame.
d) oooops, all the other tabs went to heaven.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
Created attachment 61997 [details]
Flying tabs testcase.

Updated

17 years ago
Severity: trivial → normal

Comment 3

17 years ago
Reassigning to new component owner.
Assignee: hyatt → jaggernaut
(Assignee)

Updated

17 years ago
QA Contact: blaker → sairuh
(Assignee)

Comment 4

17 years ago
-> future
Target Milestone: --- → Future
WFM on linux 2002052309 branch build.  Is this an issue still?

Comment 6

16 years ago
WFM Linux 2002051721 as well.
Bit me a couple times.
Reloading doesn't seem to work at all now, but it's better than before.

Comment 7

16 years ago
Just to reiterate: still WFM Linux 2002090508.

Now, the page appears insensitive (cannot drag and drop onto content area) but
you can drag and drop onto the tab itself.  Hitting reload does nothing. 
Switching tabs away and back shows the URL as about:blank.  Works both whether
tabs are loaded in the foreground or in the background.  If loaded in the
foreground, there is an update issue (the location bar remains empty instead of
show about:blank) but still fully functional and not representative of this bug.

This bug should be blessed with closure.
QA Contact: sairuh → pmac

Comment 8

16 years ago
Willi or anybody else, is there any reason not to close this bug?
It works for me as for all the others, there is no issue left. If it also works
for you: 
Please resolve this bug as WORKSFORME!
(Reporter)

Comment 9

16 years ago
wfm
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.