Closed Bug 1062870 Opened 5 years ago Closed 5 years ago

Filters are clipped when used in SVG-as-image

Categories

(Core :: SVG, defect)

35 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla35
Tracking Status
firefox34 --- fixed
firefox35 --- fixed

People

(Reporter: phlsa, Assigned: mstange)

References

Details

(Keywords: regression)

Attachments

(4 files)

In today's nightly, the shadow of the close/pin buttons on tiles is cut off on the sides. This doesn't happen in Aurora.
Component: General → Graphics
Product: Firefox → Core
I can confirm Kohei's assessment: this actually is a graphics issue.
Attached image image used in testcase
Attached file testcase
The top and bottom images should look identical: The green square should extend beyond the blue square's bounds.
Core:SVG is probably a better place for this bug.
Component: Graphics → SVG
Hardware: x86 → All
Summary: Shadow of tiles buttons cut off in latest Nightly → Filters are clipped when used in SVG-as-image
Version: 33 Branch → 35 Branch
The attached testcase works in Firefox 32:
 Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0
but is broken in Nightly.

So, seems to be a regression, possibly from seth's recent image-sizing refactoring work.
m-c regression range:
Last good revision: 532b5fb77ba1 (2014-09-01)
First bad revision: 372ce1f36116 (2014-09-02)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=532b5fb77ba1&tochange=372ce1f36116

The most related-looking change there seems to be:
39a8d9b2b639	Markus Stange — Bug 1059498 - Use the inner dirty rect when initializing the visible rect of display items inside the SVG filter stacking context. r=roc
Okay then!
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Yup, inbound regression range confirms that:
Last good revision: f3aa5e7c39e4
First bad revision: 39a8d9b2b639

Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f3aa5e7c39e4&tochange=39a8d9b2b639
...which is just bug 1059498's cset.
Attached patch v1Splinter Review
I'm a bit amused that this wasn't caught during review :)

The dirtyRectOutsideTransform variable isn't strictly necessary because it's always the same as aDirtyRect, but I think it's making the intention a bit more explicit. Hopefully the compiler will optimize the copy away, but if not it's probably not a big deal.
Attachment #8485079 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/cc2245e496e7
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
The fix for this was rolled into the uplift for bug 1059498 as well.
You need to log in before you can comment on or make changes to this bug.