Closed Bug 1062882 Opened 7 years ago Closed 7 years ago

Unable to add a bookmark to the homescreen from the Browser

Categories

(Firefox OS Graveyard :: Gaia::System::Browser Chrome, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.4 unaffected, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1062516
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- unaffected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: marcia, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(1 file)

Attached file nobookmark.txt
Flame, while running:

Gaia   a47ecb6368c015dd72148acde26413fd90ba3136
SourceStamp 757931d0149e
BuildID 20140904000203
Version 34.0a2
base: v123

STR:
1. Open the browser and navigate to a site
2. Long press the menu at the top and try to add the site to the home screen

Expected: it could be added
Actual: Pressing the button does nothing

Logcat attached. Some flows of add to homescreen work on today's build, including adding apps from a search to the homescreen.
Whiteboard: [systemsfe]
swapping regression-widow for a branch check first (so we know the most efficient place to begin hunting for the window)
This bug repro's on: Flame 2.2, Flame 2.1, OpenC 2.1

Actual Results: Unable to add bookmarks to the Home screen. Also the X to close the window isn't working.

Repro Rate: 5/5

Environmental Variables:
Device: Flame Master
BuildID: 20140903193339
Gaia: 008026e932b64b4a70b9931c3da96986583bc8d4
Gecko: 776fa9cf70cd
Version: 35.0a1 (Master) 
Firmware Version: v123
------------------------------------------------
Device: Flame 2.1
BuildID: 20140904091237
Gaia: 033ecff18c322bceb725f47ac97981a932d200a0
Gecko: 995e1abe3f80
Version: 34.0a2 
Firmware Version: v123
------------------------------------------------
Environmental Variables:
Device: Open_C Master
BuildID: 20140903193339
Gaia: 008026e932b64b4a70b9931c3da96986583bc8d4
Gecko: 776fa9cf70cd
Version: 35.0a1 (Master) 
Firmware Version: P821A10V1.0.0B06_LOG_DL

------------------------------------------------
------------------------------------------------

This bug does NOT repro on: Flame 2.0, Flame 1.4

Actual Result: Able to add websites to the homescreen.

Repro Rate: 0/5 attempts

Environmental Variables:
Device: Flame 2.0
BuildID: 20140904063539
Gaia: d056733f8a7a1a152f5458b323f092c47dbffa48
Gecko: 0d5b69c28413
Version: 32.0 (2.0) 
Firmware Version: v123
-----------------------------------------------
Environmental Variables:
Device: Flame 1.4
BuildID: 20140903033752
Gaia: 2ee5b00bfbb8a67a967094804390b4afce8ecf54
Gecko: f5a75c0dd74e
Version: 30.0 (1.4) 
Firmware Version: v123
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
[Blocking Requested - why for this release]: regression in a major feature
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Contact: croesch
Seems like we are looking at this in bug 1062516.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1062516
removing keywords / bug is resolved
blocking-b2g: 2.1? → ---
You need to log in before you can comment on or make changes to this bug.