Unable to start Marionette session on freshly flashed device

RESOLVED DUPLICATE of bug 1063362

Status

RESOLVED DUPLICATE of bug 1063362
4 years ago
4 years ago

People

(Reporter: davehunt, Unassigned)

Tracking

({regression})

Trunk
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
We've seen a few issues with starting Marionette sessions recently. I've been able to replicate this consistently on one of our nodes in Mountain View (b2g-25.1).

Here's what's on the device after flashing:
application_buildid: 20140904043223
application_changeset: f837b5d21533
build_changeset: 74465af039d2809454afdfef285285bb63146e1b
device_firmware_date: 1402908689
device_firmware_version_incremental: 109
device_firmware_version_release: 4.3
device_id: flame
gaia_changeset: 9c749ddc14bae186fa3ddc98e16659f122a1c1ee
gaia_date: 1409829332

Note that the flash was shallow (gecko and gaia) and can be found here: https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/tinderbox-builds/b2g-inbound-flame-eng/20140904043223/
(Reporter)

Comment 1

4 years ago
Created attachment 8484186 [details]
console.txt

Console log from Jenkins.
(Reporter)

Comment 2

4 years ago
Created attachment 8484187 [details]
logcat.txt

Logcat from Jenkins.
(Reporter)

Comment 3

4 years ago
Jonathan: Any thoughts or suggestions for what we can try? We're having a number of issues with recent builds in Jenkins and it's possible that they're all somewhat related.
Flags: needinfo?(jgriffin)

Comment 4

4 years ago
From the logcat, I'm *guessing* this is the problem, since Marionette uses XPCom for message passing:

01-22 12:07:43.489   307   307 E GeckoConsole: [JavaScript Error: "NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]" {file: "resource://gre/modules/XPCOMUtils.jsm" line: 218}]
I don't see any smoking guns, but the line you show plus the one preceding look pretty suspicious:

01-22 12:07:43.209   566   566 E GeckoConsole: Failed to load native module at path '/system/b2g/components/libxpcomsample.so': (80004005) dlopen failed: library "/system/b2g/components/libxpcomsample.so" not found
01-22 12:07:43.489   307   307 E GeckoConsole: [JavaScript Error: "NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]" {file: "resource://gre/modules/XPCOMUtils.jsm" line: 218}]

"libxpcomsample" isn't a real thing, it's just example code, and nothing should be trying to load it. Seems like something may be wonky with the build.  cc'ing dhylands in case he has any ideas.
Flags: needinfo?(jgriffin)

Updated

4 years ago
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
(Reporter)

Comment 6

4 years ago
Could be related to bug 1063362. Later b2g-inbound builds seem to not show this issue in automation, but we are still seeing bug 1062192 and bug 1062255.

Updated

4 years ago
Keywords: regression
(Reporter)

Updated

4 years ago
Blocks: 1064649
(Reporter)

Comment 7

4 years ago
Resolving as duplicate of bug 1063362.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1063362
You need to log in before you can comment on or make changes to this bug.