Puppet errors while provisioning vagrant box

RESOLVED FIXED in 102

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: dmaher, Assigned: bramwelt)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8484197 [details]
stdout.txt

Hello,

Hit some Puppet errors while provisioning the Vagrant box (master 06e41deb5e9e79a18fd1a6ef48a19b3c44f4efa9):

---
Error: /Stage[main]/Webapp::Socorro/File[pgsql.sh]: Could not evaluate: Could not retrieve information from environment production source(s) file:/vagrant/puppet/files/etc_profile.d/pgsql.sh
Error: /Stage[main]/Webapp::Socorro/File[pg_hba.conf]: Could not evaluate: Could not retrieve information from environment production source(s) file:/vagrant/puppet/files/var_lib_pgsql_9.3_data/pg_hba.conf
Warning: /Stage[main]/Webapp::Socorro/Service[postgresql-9.3]: Skipping because of failed dependencies
Warning: /Stage[main]/Webapp::Socorro/Exec[postgres-test-role]: Skipping because of failed dependencies
---

(Full output attached.)
(Assignee)

Comment 1

4 years ago
This is very strange. AFAIK nothing has changed with vagrant that would affect Postgres.

I can't reproduce on master (915fa807a0ec15fefc150efe0a1ac310886d6a0a). Will checkout exact commit and try again.
(Assignee)

Comment 2

4 years ago
This also does not show in the socorro-vagrant job at that commit:

https://ci.mozilla.org/view/socorro/job/socorro-vagrant/628/
(Assignee)

Comment 3

4 years ago
Can not reproduce on 06e41deb5e9e79a18fd1a6ef48a19b3c44f4efa9, either (x86_64 GNU/Linux).
(Reporter)

Comment 4

4 years ago
Weeeeeird - I was able to repro last night (hence the bug), but not this morning.

Possible heisenbug?  Closing out for now - I'll re-open if I can repro consistently.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Assignee)

Comment 5

4 years ago
Hmm, after looking closer at this issue (it came up for me when trying out Packer), I believe it is cause by our use of absolute paths in `source` on the `file` type; possibly coupled with differing puppet versions.

Hopefully a minor refactor of the puppet directory to create an actual socorro module will fix this.
(Assignee)

Updated

4 years ago
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 7

4 years ago
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/fbe7b4045d4f2bfd6cc2c04d82a30c3639ed7951
Refactor Puppet files to follow Puppet conventions

fix bug 1062911

https://github.com/mozilla/socorro/commit/102e697353fa2f9d05b7dc0b8f3a5ffaf8f47277
Merge pull request #2340 from bramwelt/fix-bug-1062911-puppet-socorro-module

fix bug 1062911 - Refactor Puppet Files

Updated

4 years ago
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Target Milestone: --- → 102
You need to log in before you can comment on or make changes to this bug.