Investigate the cause of differing versions of Microsoft (R) C/C++ Optimizing Compiler on Windows builders

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: markco, Assigned: markco)

Tracking

Details

(Assignee)

Description

4 years ago
From https://bugzilla.mozilla.org/show_bug.cgi?id=1057229

(In reply to David Major [:dmajor] from comment #5)
> These PGO errors look a lot like the ones we used to see before Update 2.
> Turns out, some builders don't have Update 2! Even the successful builds are
> not quite on the official release.
> 
> For reference:
> 18.00.30723 is Update 3
> 18.00.30501 is Update 2
> 18.00.30220 is ??? Maybe the Update 2 CTP or RC?
> 18.00.21005.1 is ??? Something even older
> 
> Successful PGO builds (search "18.00" in the build logs):
> https://tbpl.mozilla.org/php/getParsedLog.php?id=47005546&tree=Try&full=1
> 18.00.30220 for x86
> https://tbpl.mozilla.org/php/getParsedLog.php?id=47007220&tree=Try&full=1
> 18.00.30220 for x64
> 
> Failed PGO builds:
> https://tbpl.mozilla.org/php/getParsedLog.php?id=47003586&tree=Try&full=1
> 18.00.21005.1 for x86
> https://tbpl.mozilla.org/php/getParsedLog.php?id=47011110&tree=Try&full=1
> 18.00.21005.1 for x86
> https://tbpl.mozilla.org/php/getParsedLog.php?id=47001904&tree=Try&full=1
> 18.00.21005.1 for x64
(Assignee)

Updated

4 years ago
Assignee: relops → mcornmesser
Blocks: 1057229
Blocks: 1062877
(Assignee)

Comment 1

4 years ago
The assumption is this was being caused by an interrupted VS2013 install. Which is being handled in https://bugzilla.mozilla.org/show_bug.cgi?id=1063018.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.