Closed Bug 1062989 Opened 5 years ago Closed 5 years ago

Have separate localizable string for color filter label and heading

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.1 fixed, b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S4 (12sep)
Tracking Status
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: eeejay, Assigned: eeejay)

References

Details

(Keywords: late-l10n)

Attachments

(1 file)

colorFilter needs to have a separate heading version, as all other labels in the app are.
Comment on attachment 8484309 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23731

I shouldn't really review patches, but this one seems trivial enough.

Thanks for fixing also the other title that I didn't notice.
Attachment #8484309 - Flags: review?(francesco.lodolo) → review+
See also https://bugzilla.mozilla.org/show_bug.cgi?id=1049824#c55

We're actually reusing the string as a button inside the panel, so we should fix that too.
Comment on attachment 8484309 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23731

OK. Added distinct strings for toggle buttons of color filter and screen reader as well.
Attachment #8484309 - Flags: review?(ejchen)
https://github.com/mozilla-b2g/gaia/commit/1bfc67f0e3ef9ef3056f9607392fbb762ae69017
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8484309 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23731

I relied on flod's original review. This is a straightforward string change.
Attachment #8484309 - Flags: review?(ejchen)
Comment on attachment 8484309 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23731

Thanks for the patch Eitan :)
Asking for uplift to 2.1 now as string freeze is tomorrow.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1049824
[User impact] if declined: Not easily localizable strings for accessibility settings.
[Testing completed]: Flame 2.2
[Risk to taking this patch] (and alternatives if risky): very low
[String changes made]: yes, 4 new strings in settings.properties
Attachment #8484309 - Flags: approval-gaia-v2.1?(fabrice)
Keywords: late-l10n
Comment on attachment 8484309 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23731

low risk , accessibility improvements.
Attachment #8484309 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
v2.1: https://github.com/mozilla-b2g/gaia/commit/dcf16872b4447d03d414199908394abc3836633c
Assignee: nobody → eitan
Target Milestone: --- → 2.1 S4 (12sep)
You need to log in before you can comment on or make changes to this bug.