[Flame] Unable to flash to latest tinderbox Flame central build(s)

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: pcheng, Assigned: vicamo)

Tracking

({qablocker, regression})

unspecified
x86
Linux
qablocker, regression

Firefox Tracking Flags

(blocking-b2g:-, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Reporter)

Description

4 years ago
After flashing, the device is stuck on Firefox animation screen. We flash Gecko & Gaia on top of v123 Gonk.

From this URL, https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/tinderbox-builds/mozilla-central-flame-eng/

Last working build ID is 20140903193339

First broken build ID is 20140904060621

-------

This doesn't seem to affect Nightly channel on central as the smoke test team haven't seen this during OTA. I've tried OTA updating from nightly build ID 20140903040203 to build ID 20140904040204 and the OTA is successful.
blocking-b2g: --- → 2.2?
Keywords: qablocker
Keywords: qaurgent, regression, regressionwindow-wanted
(Reporter)

Updated

4 years ago
QA Contact: pcheng

Updated

4 years ago
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
(Reporter)

Comment 1

4 years ago
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20140903174823
Gaia: 008026e932b64b4a70b9931c3da96986583bc8d4
Gecko: 02f1b41f48b2
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20140903193524
Gaia: 5567c7d0b4408032723231490ed7e7ba1a3e0dcf
Gecko: 328db74cda4b
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First broken gecko & Last working gaia - flash is NOT successful
Gaia: 008026e932b64b4a70b9931c3da96986583bc8d4
Gecko: 328db74cda4b

First broken gaia & Last working gecko - flash is successful
Gaia: 5567c7d0b4408032723231490ed7e7ba1a3e0dcf
Gecko: 02f1b41f48b2

Gecko pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=02f1b41f48b2&tochange=328db74cda4b
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
(Reporter)

Updated

4 years ago
Keywords: qaurgent
bug 937485 looks like a suspect here.
Thanks Jason - I was having a hard time picking a suspect


Possibly broken by bug 937485, Vicamo can you take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(vyang)

Updated

4 years ago
Component: Gaia → RIL
(Assignee)

Updated

4 years ago
Assignee: nobody → vyang
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1063375
(Assignee)

Comment 5

4 years ago
Flame Gonk Feb 20:
1) Flash m-c Gecko & Gaia only: OK
2) Flash m-c whole system: OK

Flame Gonk v123:
1) Flash m-c Gecko & Gaia: FAIL
2) Flash m-c whole system: OK

Still testing some combinations like replacing libraries in /system/lib. I heard this may cause device bricked for our community members, shall we back out that patch first?

Updated

4 years ago
Blocks: 937485
Fixed via backout:

http://hg.mozilla.org/mozilla-central/rev/dddbe46f3ceb
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(vyang)
Resolution: --- → FIXED
Keywords: verifyme
removing nomination as it was fixed on master (2.2)
blocking-b2g: 2.2? → -

Comment 8

4 years ago
Verified the issue is fixed on 2.2 Flame Tinderbox build

The user is able to flash the device to the tinderbox build

Device: Flame 2.2 Master (319 Mb, Shallow Flash, Tinderbox )
BuildID: 20141126035924
Gaia: 41b7be7c67167f367c3c4982ff08651d55455373
Gecko: 7bcc6573d204
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: affected → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.