Alert comes up at window close box click (after canceling the charset alert).

RESOLVED WORKSFORME

Status

MailNews Core
Internationalization
P2
normal
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: nhottanscp, Unassigned)

Tracking

({intl})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
1) In mail compose, set charset to Japanese.
2) Type 'á' in the body and send
3) The charset alert comes up, click cancel.
4) Return to the comose window and click the window close button.
5) Alert - "mail is currently in the process of sending a message..."
(Reporter)

Comment 1

17 years ago
Created attachment 54735 [details]
Screen shot of the alert.
(Reporter)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.6
(Reporter)

Comment 2

17 years ago
Adding varada to cc.

Adding the notification (as the code below) doesn't seem to fix.

Index: mozilla/mailnews/compose/src/nsMsgCompose.cpp
===================================================================
RCS file: /cvsroot/mozilla/mailnews/compose/src/nsMsgCompose.cpp,v
retrieving revision 1.294
diff -w -u -2 -r1.294 nsMsgCompose.cpp
--- nsMsgCompose.cpp    2001/10/13 00:16:01    1.294
+++ nsMsgCompose.cpp    2001/10/23 01:35:37
@@ -894,4 +894,5 @@
           if (!proceedTheSend) {
             PR_FREEIF(outCString);
+            NotifyStateListeners(eComposeProcessDone, NS_ERROR_ABORT);
             return NS_ERROR_BUT_DONT_SHOW_ALERT;
           }
@@ -926,5 +927,8 @@
         nsCOMPtr<nsIMsgComposeProgressParams> params =
do_CreateInstance(NS_MSGCOMPOSEPROGRESSPARAMS_CONTRACTID, &rv);
         if (NS_FAILED(rv) || !params)
+        {
+          NotifyStateListeners(eComposeProcessDone, NS_ERROR_FAILURE);
           return NS_ERROR_FAILURE;
+        }
 
         params->SetSubject((const PRUnichar*) msgSubject);

(Reporter)

Comment 3

17 years ago
I talked to varada, he has some idea about this.
Assignee: nhotta → varada
Status: ASSIGNED → NEW
Keywords: intl
Target Milestone: mozilla0.9.6 → ---

Updated

17 years ago
Keywords: nsbeta1

Updated

16 years ago
Keywords: nsbeta1 → nsbeta1+

Updated

16 years ago
Priority: -- → P2

Comment 4

16 years ago
Is this really a nsbeta1+, P2? If yes, then we need to try and targeted to a
milestone M1.0 or earlier to make the beta.

Updated

16 years ago
Blocks: 122274
Status: NEW → ASSIGNED
Keywords: nsbeta1+ → nsbeta1-
No longer blocks: 122274
taking all of varada's bugs.
Assignee: varada → sspitzer
Status: ASSIGNED → NEW

Comment 6

15 years ago
*** Bug 133840 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
*** Bug 130058 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
Note that one of the dupes was entered as "critical" due to the data loss 
potential from hitting the Quit button, expecting to be able to go on and save 
the message.

Note also that attempting to save such a message also gives the same charset 
warning as trying to send it.

See my new bug 209200 for a possible better solution.
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody

Comment 10

10 years ago
This bug hasn't been valid for a long time -- the prompt about the bad characters has changed, and the handling of the "return to compose window" case (now simply "Cancel") has changed, such that this bug doesn't manifest.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.