table column width not matching between rows when containing images without width attribute

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Martin Bickel, Assigned: karnaze (gone))

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

On the table at http://www.martin-bickel.de/mozilla/bug.html , the cells of the
third row have a different width than those on the second row.

After each image in the third row, the remaining row seems to be shifted  some
more pixels to the right.This happens only when the <IMG > tag has no given
width attribute. 
At http://www.martin-bickel.de/mozilla/bug3.html is the same table with width
attributes in the image tags: no problem there.



Reproducible: Always
Steps to Reproduce:
1. visit http://www.martin-bickel.de/mozilla/bug.html
2. look at table :-)
3.

Actual Results:  the cells in the 3. row have a different width than those in
the second row

Expected Results:  all cells of the same column should have the same width

The problem exists in Mozilla 2001101202 on Linux/x86 too.

When reloading the page repeatedly the table is sometimes rendered correctly. 

A screenshot of the incorrectly rendered table is at
http://www.martin-bickel.de/mozilla/screenshot.gif

Comment 1

17 years ago
Chris - over to you. Is this a table balancing problem, or an image update
problem (or both)?
Assignee: attinasi → karnaze
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

17 years ago
Temporarily moving to future until a milestone can be assigned. 
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 3

17 years ago
I think this is fixed.  It looks right to me, and it also looks the same in IE.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

17 years ago
The bug seems to be fixed, sometime between 0.9.5 and 0.9.7. It doesn't occur
here with 0.9.7 any more.
You need to log in before you can comment on or make changes to this bug.