Text for 'Erase Device' on find.firefox.com is ambiguous

RESOLVED INVALID

Status

Firefox OS
FindMyDevice
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Parul Mathur, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8484536 [details]
fmd-erase-device-text.png

Test Environment:
Device: firefox os reference phone
BuildID: 20140904000203
Platform Version: 34.0a2
Gaia: a47ecb63
Update channel: aurora
Git commit info: 2014-09-03 20:55:15


Steps to reproduce:
1. Enable Find My Device and geo-location on the phone.
2. On another computer, go to the website https://find.firefox.com/ and sign in with the same Firefox Account used in Step 1 above.
3. Once the website has located the phone, click on the Erase option on the website.
4. Read the text that pops up to understand what happens if you choose the Erase option.

Actual Results:
The pop-up text says "Erase Device: All content will be erased. Your device will no longer be able to be located or tracked. Once you erase your device you will not be able to restore this device."
This text is ambiguous because this text does not reflect what actually happens when this option is chosen.

Expected Results:
The text reflects accurately what happens when this option is chosen:
1. All data on local storage *and* SD Card is erased. This includes photos, videos, contacts, call log, and all preferences set during First Run Experience like timezone, language, geo-location, etc.
2. The phone will reboot.
3. The phone will be restored like it's been through a factory reset.
(Reporter)

Comment 1

3 years ago
Created attachment 8484553 [details]
motorola-erase-device-text.png

Added screenshot of a Motorola phone running Android to showcase how detailed and explicit the implications of 'Erase Device' are for a Google account.
(Reporter)

Comment 2

3 years ago
Created attachment 8484555 [details]
lost-device-8.PNG

Added screenshot taken from a Motorola website to showcase how detailed and explicit the implications of 'Erase Device' are for a Google account.
https://motorola-global-portal.custhelp.com/app/answers/detail/a_id/95507

https://motorola-global-portal.custhelp.com/euf/assets/images/faqs/x-images/lost-portal/lost-device-8.PNG
Thanks for the product/UX input. I'm not sure loads of additional detail would be helpful for users with relatively little web/computer literacy, but it's something to consider.

Paging jsavory to take this input and decide what, if anything, to do with it for the website.

Whatever she'd like to do, this is not really a bug at all, since our goal isn't to do whatever Google does, and the server bugs are tracked against github anyway.

So: I'm going to ni? jsavory, close this bug as invalid, and she can open a corresponding github bug if she decides it's important to change the wording on the website.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jsavory)
Resolution: --- → INVALID
Thank you for the input, I do agree that the explanation could be a little more clear and provide some additional information. However, I don't think we necessarily need to go into quite the level of detail as the examples you have provided but we could certainly reaffirm the severity of the erase action.

I will open up another bug when I have a clear idea of exactly how to phrase the erase explanation.
Flags: needinfo?(jsavory)
You need to log in before you can comment on or make changes to this bug.