[Smart Collections] 'Create your own Smart Collection' screen displays again when the user tap cancel or ok

RESOLVED DUPLICATE of bug 1063161

Status

RESOLVED DUPLICATE of bug 1063161
4 years ago
4 years ago

People

(Reporter: psiphantong, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v1.4 unaffected, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory][2.1-flame-test-run-2], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8484590 [details]
sc.txt

Description:
'Create your own Smart Collection' screen displays again when the user tap cancel or ok

Repro Steps:
1) Update a Flame to 20140904000203
2) Long tap the homescreen
3) Tap Add Smart Collections 
4) Tap Custom
5) Tap Cancel


Actual:
'Create your own Smart Collection' screen displays again

Expected:
'Create your own Smart Collection' screen does not displays again


Environmental Variables:
Device: Flame 2.1 (319mb)
BuildID: 20140904000203
Gaia: a47ecb6368c015dd72148acde26413fd90ba3136
Gecko: 757931d0149e
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Repro frequency: 3/3 - 100%
See attached: screenshot, logcat
(Reporter)

Comment 1

4 years ago
Created attachment 8484591 [details]
2014-09-04-15-35-04.png
(Reporter)

Comment 2

4 years ago
This issue also occurs on the Flame 2.2 (319mb), Open C 2.2, Flame 2.1 (512mb), Open_C 2.1. 'Create your own Smart Collection' screen displays again


Flame 2.2

Environmental Variables:
Device: Flame Master (319mb)
Build ID: 20140904040204
Gaia: 008026e932b64b4a70b9931c3da96986583bc8d4
Gecko: 776fa9cf70cd
Version: 35.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Open C 2.2

Environmental Variables:
Device: Open_C Master
Build ID: 20140904040204
Gaia: 008026e932b64b4a70b9931c3da96986583bc8d4
Gecko: 776fa9cf70cd
Version: 35.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1

Environmental Variables:
Device: Flame 2.1 (512mb)
BuildID: 20140904000203
Gaia: a47ecb6368c015dd72148acde26413fd90ba3136
Gecko: 757931d0149e
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Open C 2.1

Environmental Variables:
Device: Open_C 2.1
BuildID: 20140904000203
Gaia: a47ecb6368c015dd72148acde26413fd90ba3136
Gecko: 757931d0149e
Version: 34.0a2 (2.1)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

____________________________________________________________________________________________________________________________


This issue does not reproduce on the Flame 2.0 (319mb), Open_C 2.0, Flame 1.4 (319mb), Open_C 1.4. 'Create your own Smart Collection' screen does not displays again

Flame 2.0

Environmental Variables:
Device: Flame 2.0 (319mb)
BuildID: 20140904000202
Gaia: d056733f8a7a1a152f5458b323f092c47dbffa48
Gecko: 19383abee78a
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open_C 2.0

Environmental Variables:
Device: Open_C 2.0 
Build ID: 20140904000202
Gaia: d056733f8a7a1a152f5458b323f092c47dbffa48
Gecko: 19383abee78a
Version: 32.0 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 1.4

Environmental Variables:
Device: Flame 1.4 (319mb)
Build ID: 20140904063007
Gaia: 2ee5b00bfbb8a67a967094804390b4afce8ecf54
Gecko: acb69ef9f3e4
Version: 30.0 (1.4)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Open C 1.4

Environmental Variables:
Device: Open_C 1.4
Build ID: 20140904063007
Gaia: 2ee5b00bfbb8a67a967094804390b4afce8ecf54
Gecko: acb69ef9f3e4
Version: 30.0 (1.4)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
This is not ideal but the user can tap cancel again to close the screen so not nominating this as a blocker.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
The 'Create your own Smart Collection' also appears again after the user created a custom smart collection. (when the user types in a term and select "OK" after step 4 from comment 0)

Flame 2.1

Environmental Variables:
Device: Flame 2.1(319mb)
Build ID: 20140908000204
Gaia: a8e4d26555e5713ec6c72270cfd0cfabc096a0d3
Gecko: 746f24f9d21d
Version: 34.0a2 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Whiteboard: [2.1-exploratory] → [2.1-exploratory][2.1-flame-test-run-2]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
While this isn't a blocking issue, it's an ugly papercut right on the homescreen. We might want to patch this up.

Cristian - Do you have cycles to look into this?
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(crdlc)
I move this bug to Ev.me because it seems that belongs to this module. I think that the right person to take a look at this one is Amir although I gonna try to help here
Component: Gaia::System::Window Mgmt → Gaia::Everything.me
Flags: needinfo?(crdlc)
I cannot reproduce it today in 2.2 (master)

Gaia: e3b9d0d6516177636965d97c63c60981a24a0662

I can reproduce it in 2.1

Alive, some idea? It seems a problem in system because the first prompt is from Smart Collection app but if you test it in your 2.1 device or watch the video, the second one belongs to home screen according to title. The home screen just creates a MozActivity to create smart collections.
Component: Gaia::Everything.me → Gaia::System::Window Mgmt
Flags: needinfo?(alive)
added qawanted because I cannot reproduce it in current 2.2
Keywords: qawanted
(In reply to Cristian Rodriguez (:crdlc) from comment #8)
> I cannot reproduce it today in 2.2 (master)
> 
> Gaia: e3b9d0d6516177636965d97c63c60981a24a0662
> 
> I can reproduce it in 2.1
> 
> Alive, some idea? It seems a problem in system because the first prompt is
> from Smart Collection app but if you test it in your 2.1 device or watch the
> video, the second one belongs to home screen according to title. The home
> screen just creates a MozActivity to create smart collections.

Sounds dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=1063161 !
Flags: needinfo?(alive)
I have tested and this problem will be fixed when the bug 1063161 is landed in 2.1
Confirmed, fixed with bug 1063161
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1063161

Updated

4 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.