How to get to the developer tools for an app is not obvious

RESOLVED FIXED in Firefox 36

Status

RESOLVED FIXED
4 years ago
7 months ago

People

(Reporter: andy+bugzilla, Assigned: paul)

Tracking

unspecified
Firefox 36
x86
macOS

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
In app manager I could start an app and there was a nice big debug button that took me to the developer tools so I could see the console. 

I was completely confused on how to do this in WebIDE until dcamp saved me in IRC by pointing out that its the "pause" button. I never would have guessed that and didn't hover over it. I realise now its the same button as the "debugger" in the developer tools.

Personally I liked the word "DEBUG", but I found the pause button confusing.
Should this just be the toolbox icon that we use in the toolbars?
Perhaps, but maybe a label is still needed?  Others have mentioned the same thing.  More discussion here, so I'll dupe to this bug.
Duplicate of this bug: 1055340
(Assignee)

Comment 4

4 years ago
What about a showing a window with a box at the bottom with "devtools" written in it? Like this: http://i.imgur.com/ivzd9Zg.png - it's explicit and has a label.

We need help from UX.
Flags: needinfo?(dhenein)
More UX flags in case that helps...
Flags: needinfo?(shorlander)
(Assignee)

Updated

4 years ago
Whiteboard: [blocked on UX]
(Assignee)

Updated

4 years ago
Blocks: 1067337
This shouldn't block bug 1067337, but will be much easier given an icon in that bug.
No longer blocks: 1067337
(Assignee)

Updated

4 years ago
Whiteboard: [blocked on UX]
(Assignee)

Comment 8

4 years ago
Created attachment 8516784 [details] [diff] [review]
v1
Assignee: nobody → paul
Status: NEW → ASSIGNED
Attachment #8516784 - Flags: review?(jryans)
Comment on attachment 8516784 [details] [diff] [review]
v1

Review of attachment 8516784 [details] [diff] [review]:
-----------------------------------------------------------------

r+++
Attachment #8516784 - Flags: review?(jryans) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/4cb2f1dff8ad
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/4cb2f1dff8ad
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 36
Flags: needinfo?(dhenein)

Updated

7 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.