Share via bluetooth from the Gallery app results in black screen

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
8 months ago

People

(Reporter: pauljt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2.1-FL-bug-bash])

(Reporter)

Description

4 years ago
Build Information
Device: Flame
Gaia      a47ecb6368c015dd72148acde26413fd90ba3136
Gecko     757931d0149e
BuildID   20140904000203
Version   34.0

Description
Tried to share a file via bluetooth, and I just get a black screen.

(NB Bluetooth not enabled or paired at prior to attempting this)

Steps to Reproduce
1. Open gallery app
2. Select photo
3. Share via bluetooth


Expected Results:
Some prompt or similar to pair a device so that it the file can be shared. Or at least an error message explaining what happened.

Actual Results:
A black screen (broken activity handler maybe?) appears over the gallery app. Have to kill the gallery app to recover.


Reproduction Frequency: 
Every time.
QA Wanted for branch checks.
Keywords: qawanted
I'm unable to reproduce this issue on the reported build. When I tap on share via bluetooth in a Gallery picture, I get a prompt 'Do you want to turn Bluetooth on?', and when tapped on 'Turn on', the bluetooth pairing screen is displayed. Repro rate: 0/5

Device: Flame
BuildID: 20140904000203
Gaia: a47ecb6368c015dd72148acde26413fd90ba3136
Gecko: 757931d0149e
Version: 34.0a2
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Happened when testing Bluetooth PTS OPP.

- Bluetooth PTS 5.2
- KK v166
- Tinderbox https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/tinderbox-builds/mozilla-aurora-flame-kk-eng/20140909171114/

TC_CLIENT_OPH_BV_01_I bug 1067822
TC_CLIENT_OPH_BV_02_I bug 1067826
TC_CLIENT_OPH_BV_34_I bug 1067835

Comment 5

3 years ago
qawanted to confirm whether this bug occurs on Aries/Flame with the latest m-c.
Keywords: qawanted

Updated

3 years ago
QA Contact: ddixon
This issue does not occur on the latest Flame and Aries builds.

Actual Results: 
When sending a photo from the Gallery app, the user is prompted with a pairing number on both the phone and the receiving device (phone or computer).  Also, the user is notified when the file has been sent and received. The Gallery app did not crash or time out with a black screen. 

Repro attempts: 0/15 

Device: Aries 2.5
Build ID: 20150810142756
Gaia: fa89e03dc489e79baa0e74cb1d205260c7924caa
Gecko: cd45a38ded04
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Flame 2.5 (full flash)
BuildID: 20150810030209
Gaia: 09dea2d5ff21cdb56da35fe4aa5bf4c90cf1da7f
Gecko: 0e269a1f1beb
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Comment 7

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.