Closed Bug 1063291 Opened 6 years ago Closed 6 years ago

[EMAIL] Can't go back in "Select a video" page while attaching video to mail.

Categories

(Firefox OS Graveyard :: Gaia::Video, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S4 (12sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: shinglyu, Assigned: pdahiya)

Details

(Keywords: regression, Whiteboard: [2.1-FL-bug-bash])

Attachments

(1 file)

Build Information
Device: Flame
Gaia      a47ecb6368c015dd72148acde26413fd90ba3136
Gecko     757931d0149e
BuildID   20140904000203
Version   34.0

Description
  When one trys to cancel attaching a video, the "<" button don't work in the "Select a video" page.

Steps to Reproduce
* Open the E-mail app with an valid account.
* Compose a new mail.
* Click the paper clip icon to attach files.
* Select "video"
* Assume the user want to cancel, click the "<" button on the top-left corner

Expected Results
  It goes back to the mail page, with nothing attached.

Actual Results
  Nothing happens, stuck in the "Select a video" page.

Other Notes


Reproduction Frequency: always
(the UI in question is part of the videos app and it's up to the videos app to cancel its activity)
Component: Gaia::E-Mail → Gaia::Video
QA Wanted for branch checks.
Keywords: qawanted
QA Contact: ckreinbring
The bug repros on Flame 2.2, Flame 2.1 and Open C 2.2
Actual result: Tapping the Back icon on the video selection page for attaching email returns no response.

Flame 2.2
BuildID: 20140908062801
Gaia: c71fd5d8c9c7cb021c97e5e9fbb29f92b50a084d
Gecko: f7a27a866c47
Platform Version: 35.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1
BuildID: 20140908022757
Gaia: e7ac3a51932f7f7a5b5a6935dcaad1343b7c5fa5
Gecko: d1b97cc46b5a
Platform Version: 34.0a2
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Open C 2.2
BuildID: 20140908062801
Gaia: c71fd5d8c9c7cb021c97e5e9fbb29f92b50a084d
Gecko: f7a27a866c47
Platform Version: 35.0a1
Firmware Version: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

--------------------------------------------------------------------------------------------------------

The bug does not repro on Flame 2.0
Actual result: Tapping the Back icon on the video selection page for attaching email returns the user to the email they are composing.

BuildID: 20140908081001
Gaia: f02a8e4ef0fabeb28593fa660a0a4ca8a5fe67e5
Gecko: 0fc1d3f1a6d7
Platform Version: 32.0
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawantedregression
[Blocking Requested - why for this release]: broken button functionality
blocking-b2g: --- → 2.1?
Flags: needinfo?(jmitchell)
QA Contact: ckreinbring
Blocking: Broken navigation and regression

Punam, please investigate.
Assignee: nobody → pdahiya
blocking-b2g: 2.1? → 2.1+
Error in logs : [JavaScript Error: "dom.pickerHeader is undefined" {file: "app://video.gaiamobile.org/gaia_build_defer_index.js" line: 729}], looks like a miss in gaia-header updates as part of bug 1015248. I will update bug with the patch. Thanks
QA Contact: jmercado
Hi Wilson
This is one line fix to get broken back button working in video pick activity header. Assigning you for review as you are familiar with gaia-header updates. Thanks
Attachment #8486581 - Flags: review?(wilsonpage)
Attachment #8486581 - Flags: review?(wilsonpage) → review+
Thanks Wilson for review, PR landed on master

https://github.com/mozilla-b2g/gaia/commit/a3225cff4550d7c66f1cb1b974482fa8284952ef
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
bug has been marked fixed, removing regression-window tag
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Please request Gaia v2.1 approval on this when you get a chance.
Flags: needinfo?(pdahiya)
Target Milestone: --- → 2.1 S4 (12sep)
Comment on attachment 8486581 [details] [review]
PR with fix of bug 1063291

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Bug 1015248

[User impact] if declined:
Bad user experience because of broken cancel button in video picker activity used when attaching videos in Email and messaging apps.

[Testing completed]:
on master

[Risk to taking this patch] (and alternatives if risky):
This is a regression in 2.1 and 2.2. Fix is a one line patch and should be  uplifted to 2.1.

[String changes made]: None
Attachment #8486581 - Flags: approval-gaia-v2.1?(fabrice)
Flags: needinfo?(pdahiya)
Attachment #8486581 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
Verified fixed on Flame 2.2 (319mb/full flash) and Flame 2.1 (319mb/full flash)

Actual result: User is brought back to the mail page, with nothing attached.

Device: Flame 2.2
BuildID: 20141010040202
Gaia: 1036b544b7e102592bd9fab95cd9317329ac1293
Gecko: 50b689feab5f
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Device: Flame 2.1
BuildID: 20141011000201
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.