[Camera] [KK] Video recording and playback is janky

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2.1-FL-bug-bash], URL)

(Reporter)

Description

4 years ago
[Blocking Requested - why for this release]:

When recording and playing back video, the quality is janky and interrupted.   See screencast of playback.

http://youtu.be/tXi3tjlWUsg

Repro:
1) install 2.1 on mozilla-aurora

Gaia      a47ecb6368c015dd72148acde26413fd90ba3136
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/757931d0149e
BuildID   20140904000203
Version   34.0a2
ro.build.date   Thu Sep 4 03:23:02 EDT 2014
ro.bootloader   L1TC00011230
ro.build.version.incremental   eng.cltbld.20140904.032250

2) Launch camera, and switch to video mode
3) start recording, and move your phone around for motion
4) Verify the video recording is janky and interrupted
5) goto Gallery, launch video, and playback the same video.  Also notice the quality is janky.   

Expected:
- smooth video recording and playback

Actual:
- janky video recording

Comment 1

4 years ago
Mike, can you please investigate.

Thanks!
Flags: needinfo?(mhabicher)

Updated

4 years ago
Whiteboard: [2.1-FL-bug-bash]
QA Wanted for branch checks.
Keywords: qawanted

Comment 3

4 years ago
Mike will be investigating this issue, assigning to him
Assignee: nobody → mhabicher
I just tried to reproduce this on my 319MB-limited Flame running:

- gonk:  v166 (kk)
- gecko: b2g-inbound:07f2836fb609
- gaia:  master:3a99e64704f1793f1bb547d19859d00721073a7c

...and I don't see anything like the problem in the video linked-to in comment 0.
Flags: needinfo?(mhabicher)

Comment 5

4 years ago
QA, Is this reproducible still on 2.1?
Unable to repro on Flame 2.2, Flame 2.1 or Open C 2.2 on 512MB or 319 MB
Actual result:  Moving around while recording video does not cause the footage to become janky.
Leaving qawanted tag up for other testers to attempt.

Flame 2.2
BuildID: 20140911063332
Gaia: e3b9d0d6516177636965d97c63c60981a24a0662
Gecko: 98ea98c8191a
Platform Version: 35.0a1
Firmware Version: v165
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1
BuildID: 20140910165554
Gaia: d61264cd0c1f797b6be11e33524d8d52983c87e4
Gecko: 1d44dfce2e5b
Platform Version: 34.0a2
Firmware Version: v165
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Open C 2.2
BuildID: 20140911063332
Gaia: e3b9d0d6516177636965d97c63c60981a24a0662
Gecko: 98ea98c8191a
Platform Version: 35.0a1
Firmware Version: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Comment 7

4 years ago
Renom if this is still happening. If not, please close as works for me.
Assignee: mhabicher → nobody
blocking-b2g: 2.1? → ---
I was unable to reproduce this issue on the latest  Flame KK 2.2 or Flame KK 2.1.  I do not have access to the reporter's build, but was also unable to reproduce this issue on the closest available 2.1 build.

10 attempts per build.
0/30 attempts reproduced this bug.

Environmental Variables:
Device: Flame 2.1
BuildID: 20140923142342
Gaia: b542080231bb9cdbdb282ab926965ad3f91f7460
Gecko: fab3c895bc89
Version: 34.0a2 (2.1) 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20140923141844
Gaia: 37b8a812c642ca616bf9457cb9b71e45261cdfa8
Gecko: 9472206fdd12
Version: 35.0a1 (2.2) 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Environmental Variables:
Device: Flame 2.1
BuildID: 20140904062538
Gaia: a47ecb6368c015dd72148acde26413fd90ba3136
Gecko: ffb144a500a4
Version: 34.0a2 (2.1) 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Flags: needinfo?(jmitchell)
resolving per comment 7
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(jmitchell)
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.