If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

browser_signintowebsite.js should wait for load and then check content window's location against something real

RESOLVED DUPLICATE of bug 1243089

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1243089
3 years ago
2 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

This function:

http://mxr.mozilla.org/mozilla-central/source/browser/modules/test/browser_SignInToWebsite.js#239

does:

256   let winObs = new WindowObserver(function(authWin) {
257     ok(authWin, "Authentication window opened");
258     ok(authWin.contentWindow.location);
259   });

unfortunately at this point authWin hasn't loaded yet (the executeSoon in WindowObserver won't change that most times) so the chrome side of the window won't have loaded, nevermind the content side. The assertion actually currently throws an exception which is swallowed silently. bug 1062631 gets rid of the exception swallowing, so we just have a broken test.

Matt, I don't really know if we plan on fixing all this stuff for Firefox Accounts, or ripping it out, or enabling it to prop up the current version of Persona, or what, but I hope you do! :-)

(for now, I'm going to recommend to comment out the assertion so bug 1062631 can move ahead)
Flags: needinfo?(MattN+bmo)
Flags: in-testsuite+
(In reply to :Gijs Kruitbosch from comment #0)
> unfortunately at this point authWin hasn't loaded yet (the executeSoon in
> WindowObserver won't change that most times) so the chrome side of the
> window won't have loaded, nevermind the content side. The assertion actually
> currently throws an exception which is swallowed silently. bug 1062631 gets
> rid of the exception swallowing, so we just have a broken test.

It seems like this wouldn't be hard to fix, right?

> Matt, I don't really know if we plan on fixing all this stuff for Firefox
> Accounts, or ripping it out, or enabling it to prop up the current version
> of Persona, or what, but I hope you do! :-)

I wish I did but I don't know what the identity team has in mind. Last I heard there were still changes wanted to the BrowserID API before we would enable any native integration on desktop. I just sent an email to mozilla.dev.identity to get feedback: https://groups.google.com/d/topic/mozilla.dev.identity/YH5mzZSvj1c/discussion

> (for now, I'm going to recommend to comment out the assertion so bug 1062631
> can move ahead)

That's fine and I see this landed.
Flags: needinfo?(MattN+bmo)
Blocks: 1095617
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1243089
You need to log in before you can comment on or make changes to this bug.