Clicking a <label> doesn't give focus to <input type="checkbox"> if the label is wrapped

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
P2
minor
RESOLVED WORKSFORME
16 years ago
3 years ago

People

(Reporter: Jonas Jørgensen, Assigned: rods (gone))

Tracking

({html4, testcase})

Trunk
Future
x86
All
html4, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [HTML4-17.9.1])

Attachments

(5 attachments)

(Reporter)

Description

16 years ago
Clicking a LABEL only gives focus to the corresponding INPUT if you click the
first line of the label. If the label is wrapped and you click the second line,
nothing happens.
(Reporter)

Comment 1

16 years ago
Created attachment 54771 [details]
Testcase
(Reporter)

Updated

16 years ago
Keywords: testcase

Comment 2

16 years ago
this is probably caused by the changes made in the fix for bug 47149
maybe layout rather than form?
(Assignee)

Comment 3

16 years ago
it's a dup

*** This bug has been marked as a duplicate of 107621 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
Are you sure this is a dup of the bug about <label>s for <select> elements not 
working at all?

Comment 5

16 years ago
This doesn't look like a dup to me. That is about doing something when a <label>
clicked is associated with a <select> but this is about <label> not triggering
when it is wrapped.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Updated

16 years ago
Status: REOPENED → ASSIGNED
Target Milestone: --- → mozilla1.2
(Assignee)

Updated

16 years ago
Priority: -- → P2
Target Milestone: mozilla1.2 → Future

Comment 6

16 years ago
Created attachment 71089 [details]
testcase (with hover)

with this testcase this almost look like bug 98783 except for the fact that bug
98783 is fixed and this is not.
Reopen if you disagree with this duplication.

*** This bug has been marked as a duplicate of 28657 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 8

16 years ago
That bug is about <label> not working for <input type="text"> at all. This bug
is about it not working for <input type="checkbox"> if the <label> text is wrapped.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Clicking a LABEL doesn't give focus to INPUT if the label is wrapped → Clicking a <label> doesn't give focus to <input type="checkbox"> if the label is wrapped
Keywords: html4
Whiteboard: [HTML4-17.9.1]

Updated

15 years ago
QA Contact: madhur → tpreston

Comment 9

15 years ago
Confirmed on Linux with the following build:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020513

Note that this issue may also be forced using <BR> tags (which
validates as HTML 4.01 Transitional).  Will post another testcase.

I've also observed that MS Internet Explorer 5.5 (IIRC) behaves
correctly and makes wrapped labels clickable when using <BR> tags
to force the wrapping.
OS: Windows 2000 → All
Created attachment 85323 [details]
testcase (with br tags)

A test case using <BR> tags to force the line wrapping issue.
Behaves the same as all of the previous testcases.

Comment 11

15 years ago
All the testcases WFM on Linux build 2002071914.

Comment 12

15 years ago
If you mousedown on, say, line 2, then drag the mouse to highlight a few words
and then mouseup somewhere in line 4, then test case in attachment 85323 [details] will
not work.

If you mousedown on, say, line 2, then drag the mouse to highlight a few
characters on the same line and then mouseup in line 2, then test case in
attachment 85323 [details] works.

All other testcases WFM on Windows XP Pro build 2002072918 .

Comment 13

15 years ago
My previous comment is not really useful in this bug. Dragging/highlighting text
in a label has nothing really to do with a simple click in a label element.

I'm uploading 2 additional testcases regarding this bug; they are the same as
attachment 71089 [details] and attachment 85323 [details]. The difference is located only in the
respective format (implicit versus explicit) of the label element.

So, all testcases WFM on Windows XP Pro with build 2002080218. I think this bug
should be resolved just like bug 28657 was resolved a few days ago.

Comment 14

15 years ago
Created attachment 93833 [details]
Implicit version of attachment 85323 [details]

Explicit refers to this kind of format:
<label for="idRef">text of label</label><input type="checkbox" id="idRef">

Implicit refers to this kind of format:
<label>text of label<input type="checkbox" id="idRef"></label>

Comment 15

15 years ago
Created attachment 93834 [details]
Implicit version of attachment 71089 [details]

Explicit refers to this kind of format:
<label for="idRef">text of label</label><input type="checkbox" id="idRef">

Implicit refers to this kind of format:
<label>text of label<input type="checkbox" id="idRef"></label>

Comment 16

15 years ago
All testcases WFM on Win98/2002090316.

Comment 17

15 years ago
I wish the following keywords be added to this bug:  access , nsbranch+ and sec508

Comment 18

15 years ago
So far, 3 different people (the last 3 who made comments) using 3 distinct os
have been saying that the test cases WFM.

Can we resolve this bug as WFM ?
(Reporter)

Comment 19

15 years ago
WFM.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.